PDA

View Full Version : Car troubles Pls help


kencobra
12-09-2005, 07:31 PM
Coming home from work today the Cobra started acting really wierd. First the radio started losing power and the ABS light on the dash came on and the dash lights dimmed. Then the radio went off for good and every time I gave the car some gas it fell flat on its face. It never died but I sure thought it might so at the stop lights I kept it reved up.
Nothing mechnical has been done to the car lately except for a new pair of rear tires on tuesday. I have used half of a tank of gas since fill up.

I do not think it is a fuel problem at all. It has to be something electrical and my only thought is the alternator. The car has just turned 26,000 miles this week and there has been no issue until today.

What do you guys / gals think ?

kencobra
12-09-2005, 07:46 PM
Just went to try and start the car but it would not start but the radio came back on. Now Iam thinking either battery or alternator.

97CasperCobra
12-09-2005, 08:22 PM
I would say alternator Ken. They usually aren't too bad...about $200 at O'Reilly and are pretty easy to install. Let us know Ken. :thumbsup:

jimmysidecarr
12-09-2005, 11:02 PM
Alternator(known issue) The most likely cause... from the symptoms described...
Bad engine ground(less common issue)
Battery(as a result of a bad alternator...IE: they may both be bad) non deep cycle batteries don't survive long when deep cycled...

Is the warranty out??? 3/36 comes around fast I know...

There are alternators that kick A$$ if you want something better than stock... and WAAAY better than the "El Cheapo" parts store re-builts...

LINK to the best alternators I have been able to find--> http://www.pa-performance.com/9902cobra.asp

Link to excellent informative alternator(Terminator) threads--> http://www.modularfords.com/forums/2003-2004-svt-cobra-terminator/another-alternator-thread-40329.html?highlight=alternator

http://www.modularfords.com/forums/2003-2004-svt-cobra-terminator/pa-130-alternator-kicks-ass-datalog-below-38448.html?highlight=alternator

:thumbsup:

kencobra
12-10-2005, 12:07 AM
Thanks guys for the info and Jimmy you always come up with some of the best and most interesting reading. Not sure what to do as I need to get this fixed tomorrow am. The car did start again but not very strong. I plan to go to Autozone or Oreilly in the morning have both alt. and battery tested. I am guessing that our stock alt is 120amp ?

Now I wish I would not have spent the extra bucks tuesday on the Goodyear 315 35 17 GS D3's.

97CasperCobra
12-10-2005, 01:50 AM
Now I wish I would not have spent the extra bucks tuesday on the Goodyear 315 35 17 GS D3's.

but they look so damn good!!!! :D

let us know if you need any help installing the alternator/battery Ken. :thumbsup:

kencobra
12-10-2005, 11:43 AM
Had it checked and the diodes are bad. Only place to get one today is Ford @255.00 :mad:

AirForce1
12-16-2005, 01:56 PM
sorry to hear that ken.....

My gf's mother has a 2002 gt that wont start that i have been trying to get running. when you got to start it the only thing you hear is the starter click.

Even with a new battery it still does the same think.

Jimmy what do you think?

Could the starder be bad?.......I called chris and he said that he has never had a problem with a mustang starder. He thinks it could be the battery cables.

The starter clicks so Does that mean it is ok? or could it be frozen?

Any good ideas?

03 cobra toy
12-16-2005, 04:23 PM
Had it checked and the diodes are bad. Only place to get one today is Ford @255.00 :mad:


I had the same problem... :mad:

bluethunder
12-16-2005, 05:15 PM
Ken post a part Number or call me and Let me see what I can get it for you for. I might be able to get it cheaper.
281-250-4365

jimmysidecarr
12-16-2005, 05:16 PM
sorry to hear that ken.....

My gf's mother has a 2002 gt that wont start that i have been trying to get running. when you got to start it the only thing you hear is the starter click.

Even with a new battery it still does the same think.

Jimmy what do you think?

Could the starder be bad?.......I called chris and he said that he has never had a problem with a mustang starder. He thinks it could be the battery cables.

The starter clicks so Does that mean it is ok? or could it be frozen?

Any good ideas?
YES

It could be...

A bad ground connection...
Which could be...
At the engine end of the negative battery cable...
Or the battery end of the negative cable...

Or it could be a bad connection at the positive cable... most likely at the battery end...

The battery cables could be corroded which raises the resistance even with the ends replaced...

The alternator could be bad...
If an alternator diode fails it allows the fields to remain energized even when the car is shut off...

This will pull down(discharge) a brand new battery and could possibly KILL IT!!!

Or
The starter could be bad...

Have it tested by someone with the proper equipment and knowlege...

So you don't buy non returnable electrical parts!!!

:thumbsup:

97CasperCobra
12-16-2005, 09:11 PM
Ken post a part Number or call me and Let me see what I can get it for you for. I might be able to get it cheaper.
281-250-4365

sure...just tow it to ya and you'll charge someone with a simple install right??? :rolleyes:

bluethunder
12-17-2005, 10:04 AM
sure...just tow it to ya and you'll charge someone with a simple install right??? :rolleyes:


Look Smart Ass, I'm just trying to get him the best deal on the Part. Never said I'd install it.

kencobra
12-17-2005, 11:47 AM
I did get it fixed last saturday. Bought the alt from T. Vaughn Ford and installed myself. Thanks for the responses.