PDA

View Full Version : belt squeal please help


spincobra03
03-13-2006, 04:03 PM
Ok so Dan helped me with my A/F running in the 11's so im ok there. Now I still have a constant squeal especially when first start up. Usually after a half hour of drive time it seems to lesson and sometimes stops completly. But sure enough it comes right back. Now I just got a 6lb lower with the alternator pulley in from LFP. They sent me a 79 gator back belt but it was an inch short. There were three of us trying to get the belt on, even rolling it on didnt work, so it was def to short. I picked up a NAPA 81 inch belt and we got that one on after rolling it on(I cant tighten it any more so I know its not slipping) I did notice after like 75 miles the sides of the napa belt I can start to see a little bit of cord, which is telling me that its rubbing. Both the lower and the upper seem to fit with more than enough room but the alternator pulley seems where I might be having the problem but im not sure. Now when I talked to LFP he said the 79 's are the belts they use but my mech says theres NO WAY that 79 will fit, so LFP is sending me an 81 gator back. Does anyone have any suggestions. The noise is so loud that I can hear it over my exaust at crusing speed. ITs annoying!

AirForce1
03-14-2006, 02:02 PM
Ok so Dan helped me with my A/F running in the 11's so im ok there. Now I still have a constant squeal especially when first start up. Usually after a half hour of drive time it seems to lesson and sometimes stops completly. But sure enough it comes right back. Now I just got a 6lb lower with the alternator pulley in from LFP. They sent me a 79 gator back belt but it was an inch short. There were three of us trying to get the belt on, even rolling it on didnt work, so it was def to short. I picked up a NAPA 81 inch belt and we got that one on after rolling it on(I cant tighten it any more so I know its not slipping) I did notice after like 75 miles the sides of the napa belt I can start to see a little bit of cord, which is telling me that its rubbing. Both the lower and the upper seem to fit with more than enough room but the alternator pulley seems where I might be having the problem but im not sure. Now when I talked to LFP he said the 79 's are the belts they use but my mech says theres NO WAY that 79 will fit, so LFP is sending me an 81 gator back. Does anyone have any suggestions. The noise is so loud that I can hear it over my exaust at crusing speed. ITs annoying!
what year is your car 01-99? when they put on my kb i had a belt squeel and it turned out to be that the belt was so tight that one of the idlers was not getting enough belt on one of the lower idlers. ( and that could be because I have a blower so i would have more idlers is you have a non supercharged car) I would go and but a can of belt dressing. start the car and while it is on go and lissen and find where the noise is comming from and then spray the belt dressing on the belt and then turn it off. Go back and look at all the pullies and if there is a lot of build up of black streeks on a certian pullie that means that pullie is not getting enough belt and would creat the squealing. If that is not the problen or you have already tried that I would look at the berings in the center of the pullies and if one of those is bad then that yould cause the pully to wabble when it spines and yould cause the belt to rubb. That is just my two cents I could be wrong. Just let us know how it comes out.:thumbsup:

Ram77mus
03-14-2006, 06:47 PM
I HAVE HEARD OF PROBLEMS FROM THE STOCK IDLER PULLEYS MAKING NOISE WHEN GOING BAD. BUT YOU SAID IT STARTED AFTER THE PULLEY CHANGE! HMMM. I ALSO HAVE HEARD THAT SOME ALT. PULLEYS NEED SOME SORT OF SPACER. HMMMM:scratch:

RD SNAKE
03-15-2006, 08:04 PM
look for cracks on the any of the pulleys. make sure ur belt have some play in it. also make sure there is no big black marks somewhere on the pulleys

flynfink
03-15-2006, 08:26 PM
I HAVE HEARD OF PROBLEMS FROM THE STOCK IDLER PULLEYS MAKING NOISE WHEN GOING BAD. BUT YOU SAID IT STARTED AFTER THE PULLEY CHANGE! HMMM. I ALSO HAVE HEARD THAT SOME ALT. PULLEYS NEED SOME SORT OF SPACER. HMMMM:scratch:

Hey Rob, TURN OFF THE CAPS LOCK PLEASE...

BOOMER23
03-16-2006, 03:43 PM
I HAVE HEARD OF PROBLEMS FROM THE STOCK IDLER PULLEYS MAKING NOISE WHEN GOING BAD. BUT YOU SAID IT STARTED AFTER THE PULLEY CHANGE! HMMM. I ALSO HAVE HEARD THAT SOME ALT. PULLEYS NEED SOME SORT OF SPACER. HMMMM:scratch:

That is definately true but Ill tell ya when I had my 99 cobra it was squealing just a little bit but not enough to warrant me worrying but I had a beach trip coming up so I replaced my sorta worn out belt with a different brand and it was slightly tighter when the ford place put it on the damn idler was squealing so bad it was crazy and what i found out had happened was the bearings were going bad in one of my idlers so when i put the different brand belt which was slightly tighter than the stocker it made the bearings have more load on them and make more noise so i knew she was going out, had the idler replaced and bingo..no more squealing and everything was fine with the new belt, so you may have an idler going out