PDA

View Full Version : 94 cobra electrical problems


Eric_red94
06-21-2006, 02:11 PM
My cobra is bogging hard and falling on it's face periodically. It has an msd coil and msd 6al ignitinon, 80mm mass air. The problem seems to be ignition related, it is vortec supercharged and a 331. When it bogs, the tach jumps all around like it is on crack. Leading me to think it is electrical related to the tach, maybe the coil, etc. Any advice would be appreciated. Thanks

Eric

venomous
06-21-2006, 04:50 PM
I have heard of people having probs with MSD ignitions. Try switching back to the stock ignition and see if that helps. Maybe the coil as well try the stock one.

TL04SVT
06-22-2006, 07:51 AM
Ive also heard about msd having problems.... my 93 had the same symptoms yours does... the tach would jump all over. I replaced the distributor with a stock remanufactured one and the problem went away. I would say its either your ign. control mod or stator.

Eric_red94
06-22-2006, 11:28 AM
Probably will change out the coil, distributor and maybe trash the ignition. Appreciatte the help!

Eric

Eric_red94
06-26-2006, 10:10 AM
looks like my problem was the Anderson Ford MS power pipe falling off the back of the vortech again. I can't keep it on there more than a few runs, stupid thing. It seems to be a bad design, or just a pain in the but.

Eric

venomous
06-26-2006, 10:28 AM
Glad to see you got it fixed! When I first got my JLT intake it kept coming off the TB and till got me a better clamp and it stayed. :thumbsup:

Eric_red94
06-26-2006, 04:21 PM
I got the pipe on good and promptly went out and blew a head gasket. Guess those o-rings and lockwires on the afr185 heads only last a few months.:mad:
Tear it down and put it back together again. Seems to be a recurring theme with forced induction. Pay to play. Had a really safe tune, too. Odd.

Eric

venomous
06-26-2006, 05:47 PM
What type head gaskets did you use? Cometic heads gaskets are really stout and take alot of abuse. :thumbsup:

Eric_red94
06-27-2006, 10:29 AM
Apparentlly didn't blow a gasket, something caused the car to overheat, fan, thermostat, vapor lock? Any how went out last night and ran the dog chit out of it and it is fine. Probably race it tonight. Got that power pipe on good now.

Eric