PDA

View Full Version : Brake Problem!


hi ofcr cobra
01-24-2007, 11:07 PM
I could use a little help guys! Last weekend I ran 1 day at TWS, the car did great (and i pushed it pretty hard) until a later session when I sputtered a bit on the back strait and noticed I was almost out of fuel. I ran about 7/10s back to the paddocks and refuelled...

Here's where the problem starts...

When pulling away from the pumps I tried to brake and the pedal hit the floor!!! I gave it a few pumps and luckily got pressure back. I let the brakes cool for an hour or so and gave them a try again, now when I hit the pedal it travels about 75% to the floor and I get some pressure, but after that first "pump" my pedal becomes firm again. If I let off the brakes for about 5 seconds then press them they are very soft again.

I tried flushing the fluid thinking I may have just boiled it, I definately got some very dark fluid out + a little air. But now the problem has changed... before it was a very soft pedal followed by a firm pedal, now it is a somewhat soft pedal all the time.

any ideas?

I have been told it could be pad knockback, but the IRS + floating calipers + it hasnt gone away makes me think that isn't the problem.

I did do one stupid thing during this ordeal... while stopping to fuel (for about 10 min) I had my parking brake on, clamping my pads down on some very hot rotors! :doh2: I dont know if this has anything to do with my problem, but i figured it was worth mentioning.

Oh, and I am running stock everything except hp+ pads in front and hps pads in back.

johnbasf
01-25-2007, 06:42 PM
Try bleeding the master cylinder and the ABS block.

cobrabitn
01-25-2007, 11:23 PM
I have the same problem with my 94 and I plan to replace all calipers on it next month. I'll also be bleeding the MC! :thumbsup:

Stack
01-26-2007, 08:57 AM
I tried flushing the fluid thinking I may have just boiled it, I definately got some very dark fluid out + a little air. But now the problem has changed... before it was a very soft pedal followed by a firm pedal, now it is a somewhat soft pedal all the time.

any ideas?

I have been told it could be pad knockback, but the IRS + floating calipers + it hasnt gone away makes me think that isn't the problem.

I did do one stupid thing during this ordeal... while stopping to fuel (for about 10 min) I had my parking brake on, clamping my pads down on some very hot rotors! :doh2: I dont know if this has anything to do with my problem, but i figured it was worth mentioning.

Oh, and I am running stock everything except hp+ pads in front and hps pads in back.Sounds to me like you have a few things going on here... 1st... you did boil your fluid, plain and simple. I personally don't think HP+ pads are up to the task of track days except on cars much lighter than your own. That, plus the parking brake thing didn't help matters. Knockback (from what I hear, never experienced it myself) is usually only felt on the first pedal push, the second should be fine, so I don't think its that.

I think its a combination of still having air in the lines and you've probably lost quite a bit of pad material. Wouldn't hurt to check that you don't have a cailper sticking as well... as was suggested, do a complete bleed and flush with a high-quality racing-type synthetic fluid (Motul RBF600, AP 550, ATE 200 to name a few) including the abs block and master cylinder. Replace the pads with something like Hawk HT-10s, Ferodo 2500, Pagid Yellow... and I think you'll be good to go. While you're at it, put some braided stainless steel lines on if you haven't already.