PDA

View Full Version : Whipple install completed


Big T
04-23-2007, 11:23 PM
Well I finally finished my whipple install. I work a lot so the install took me around a month to do. I worked on it a few hours here and there on the weekends. I don't have a lot of mechanical skills, but with the use of this forum and ATS I was able to complete the job. I enjoyed it and learned a great deal in the process. My car seems to run smooth and the new Accufab TB feels nice. I'm going to go easy on it until I get a fuel pressure gauge and a good dyno tune. Dyno numbers will come soon.

ausie
04-24-2007, 06:51 AM
The only drive I would recommend is to a tuner so that you are not running too rich which is just as bad as running lean. Sooner or later I will have to bend in that direction and whipple or KB my 04 but I do not know of any tuner's in my immediate area.

blk04cobra1
04-24-2007, 09:27 AM
Congrats on completing the install :thumbsup:

Big T
04-24-2007, 10:01 PM
The only drive I would recommend is to a tuner so that you are not running too rich which is just as bad as running lean. Sooner or later I will have to bend in that direction and whipple or KB my 04 but I do not know of any tuner's in my immediate area.
Yeah. I don't have any tuners down here that I know of, but hopefully we can get another dyno day together with ATS in the near future. Luckily it is not my daily car and I can afford to be patient with it. I'm going to do some data logging and send it off to check the tune.

03bloodredsnake
04-26-2007, 03:15 PM
The only drive I would recommend is to a tuner so that you are not running too rich which is just as bad as running lean. Sooner or later I will have to bend in that direction and whipple or KB my 04 but I do not know of any tuner's in my immediate area.you are in luck i know 2 around here let me know