PDA

View Full Version : Brake problem?? Need help.


97Whitesnake
06-08-2007, 02:05 AM
My car started making a shreaking sound during low speed left turns a while back. Upon inspection of the drivers side rear brake I noticed that the rotor is rubbing on the bracket that the caliper is mounted on. The outer edge of the rotor is now rounded. Any ideas??
Thomas

cobrabitn
06-08-2007, 08:22 AM
Soounds like your rotor is warped. Raise the vehicle, take off the wheel, and visually inspect the rotor for trueness by turning it. If it wobbles or moves from side to side, it is time for a new rotor.

dewone
06-08-2007, 05:10 PM
Check the wheel bearings also. As well as the caliber mounts. Sounds like there may be some slop in there for it to only rub while turning. .02 good luck

johnbasf
06-08-2007, 09:06 PM
Check the wheel bearings also. As well as the caliber mounts. Sounds like there may be some slop in there for it to only rub while turning. .02 good luck

I second the wheel bearing theory.

97Whitesnake
06-08-2007, 09:47 PM
I dont think its the rotor... ther wear is the same all the way around. The rotor is definetely rubbing on the caliper mount and it is only during left cormers. I had suspected that there my be too much lateral slop in the rearend so I'll look into the bearings... that sounds as if it might be the problem.
Update... I inspected the set of rotors that I took off a couple of months ago and the one from the side in question is also round a little bit. This makes me lean more towards bearings.

97Whitesnake
06-10-2007, 06:03 PM
Took a look at the bearings last night. After we took the cover off the pumpkin and drained the fluid we noticed that there was a lot of play in the rearend. If I grabbed the ring gear it will move side to side over a half of an inch. Should there be this much play in the rearend?

97Whitesnake
06-23-2007, 07:01 PM
Problem solved,
When we took the diff housing out it was easy to see what was wrong. One of the housing bearing was completelly shot. It was all mangled and looked as if it would not was another mile in the car... all the shims were mangled too. The machine shop that took the bearings of and pressed on new ones said the bearing fell apart in their hand when they took it off. I had been thinking that my tranny was making LOUD noises and I was getting ready to switch it out bu it was the rearend making all the noise. Also switched out the stock radiator for an 03 unit and my cooling issues look to be fixed... I can use the AC now!!

Almost ready for VIR!!