PDA

View Full Version : Having a problem with the radiator fan.


texaswrx
04-05-2008, 07:27 PM
Casual driving today on a cool for Houstin day (80s) I noticed my water temp higher than usual(just at 200f,scangauge). Luckly, I was close to home, and checked it out in the garage. My fan is making a whiring type noise and the entire assembly is moving when the fan comes on(I also let it cool, unbolted and moved the radiator resevoir, and could see nothing missing). I could find no bolts missing on the shroud. When I opened the hood I noticed a burnig smell, and using a good light, there was a faint smoke coming from the fan motor area. The only thing out of place was a small piece of rope (very small and shredded). Is it possible to have a piece of string wrap itself around the roatating (shaft) part of the fan (and this is causing a balance problem) ? The car is an 04 with a mostly easy 19k miles.


Any tips on pulling the fan assembly? It Looks rather straight forward.


Thanks

jimmysidecarr
04-06-2008, 01:09 AM
With the resv. removed it is a pretty easy removal.
I would check to see if the debris has wrapped around the fan motor shaft. If it did try and remove it all and retry the cooling fan by turning on the A/C and ignition.

If it still seems injured:( call me Monday at work, Northwood Lincoln Mercury 281 539 4950, ask for Jim, remind me who you are (John:D ) and I'll get you a price on a new fan.

If you have had no cooling issues prior to this I would go back with a stocker.
If you have some fabrication skills and can afford to have the car down while you modify it, a Mark 8 fan pulls the highest CFM of all OE Ford cooling fans.

It is NOT, a bolt on affair however.

texaswrx
04-06-2008, 03:49 PM
Thanks Jimmy. I will pull out the fan assembly and see if there is anything easily removable. And no, never had any cooling problems at all. The scangauge just 200 on water temp, and the highest I have ever recalled was ~192 in the dead summer.

03 cobra toy
04-06-2008, 05:03 PM
I would check the fan blade ring. I have seen a few crack and cause all sorts of noise. If it is you will have to buy the whole fan assy..... $$$

Carl G
04-07-2008, 08:03 PM
I would check the fan blade ring. I have seen a few crack and cause all sorts of noise. If it is you will have to buy the whole fan assy..... $$$
It will also cause the car to heat up, know from experience :thumbsup: