PDA

View Full Version : 2001 Cobra SVT Water Pump Keeps Leaking After I Replaced It For The 5th Time


Robert Montoya
05-07-2009, 11:06 PM
Can Someone Tell Me Something I Dont Know? PLEASE It Leaks From The Little Hole Under The Freeze Plug. I Dont Know What I Can Do , I Replaced A Few Pulleys With The Factory Parts From Ford and A couple Mechanics Looked At It . Its A Mystery to Me .Theres got to be something else i can try, Any Suggestions?

cobrabitn
05-08-2009, 09:59 PM
5 times on a waterpump?? Sounds like the surface is uneven somewhere?

dougstang
05-09-2009, 12:55 PM
I hope you didn't use one of the Lifetime guarantee water pumps from the discount stores?????

:thumbdwn:

:flush:

Robert Montoya
05-09-2009, 10:24 PM
No its a Ford Motorcraft Part

Mystic_Cobra
06-02-2009, 12:25 AM
No matter where the part came from, I have to believe the problem is with the block or the installation process. There's no way you could end up with that many pumps.

Philcsag1
06-03-2009, 06:36 PM
did you put the "o" ring on the water pump?

Robert Montoya
06-07-2009, 01:49 AM
It was the radiator cap, I took the ford part back and got my money back and went to napa and got some helpful info from them finally some one gave me an answer that makes sense. Thanks for all the feedback guys. The radiator cap was the original one from the factory and it was the only part in the system that was not replaced guess im getting old and forgetting all the tricks LOL.:thumbsup:

Philcsag1
06-07-2009, 10:00 AM
How does a bad radiator cap look like leaking water pump?