PDA

View Full Version : 96 Cobra Sensor or Switch Confusion


TT96cobra
09-01-2009, 04:21 PM
I have been attempting to research what PART I need to replace on my 96 Cobra. The temperature gauge in the dash is buried to the left (Cold) side of the "idiot" gauge and I just want it to work normally. I understand that the gauge is not the greatest for accuracy, but I just want it to work properly and offer me some kind of reading. So, long story short.....I believe it is the part on the right side of the motor (as you are looking at it from the front of the car) that is the part that works the temp gauge in the car. I have checked the connector and the part itself looks good (only 1500 miles on car), but I am not getting any reading on the gauge. Is this the sensor or the switch on the right side???? The part has a threaded post coming from it and there is one Red/White stripe wire that runs to the part. Should I replace this part or look at something else??

Thanks for your help...... Oh and I did search for this information, but that is my frustration, ever post I look at gives me a different answer as to if it is a sensor or switch and where it is REALLY located at. :)

TT96Cobra

TT96cobra
09-01-2009, 05:04 PM
I know this question has probably been asked a lot, but can someone please give me some accurate information.

Thank you,
TT96Cobra

TT96cobra
09-01-2009, 05:35 PM
Got my question answered........Thanks.

cobrabitn
09-01-2009, 09:52 PM
Post what you found so others will know for future reference and glad you got it fixed. :D