PDA

View Full Version : 1998 cobra check engine light on running lean


pvtdiaz
09-26-2009, 08:15 PM
I have a 1998 cobra when i bought it the check engine light would come on for a while and it would idle high like 1500rpm it would take a long time to go back to normal idle then the check engine light would turn off its been six months since now the check engine light stays on and i have the same idle problem when i drive the car agressivly only i had the codes read it says its running lean in bank one and two i had a technician diagnose it and he said it was a leak in the rear of the lower intake manifold. so is that possible? is there any aftermarket lower intake manifolds? any help would be appreciated.

SuperG
09-28-2009, 09:53 AM
I wonder if you could also have a bad O2 sensor(s)...hopefully someone smart will chime in!

nckissfan
09-28-2009, 09:56 AM
I second the bad 02 sensor

pvtdiaz
10-01-2009, 04:53 PM
i changed the two front ones with brand new bosch ones and the two rear ones are denso's they look good

cobrabitn
10-01-2009, 10:25 PM
Well, that's possible but I would check other items first before I went into taking the intake off or apart.

1. Check the idle position sensor for proper setting
2. Check to see if the MAF sensor is clean and doesn't have dirt on it.
3. You don't really tell much about that car, is it stock or are there headers on there? Could you have a vacuum leak prior to the sensor in which it will make it seem like it has a lean condition when it doesn't?

:scratch:

pvtdiaz
10-02-2009, 09:08 PM
well i took the car to the ford dealer they finally found the problems it is a vacuum leak from the intake but also they told me i am going to need the imrc plates so i was wondering if i should delete or replace them with new ones and if anybody know any mechanics in the los angeles area