PDA

View Full Version : 96 Cobra Electrical Problems


SnowWhtSnake
04-06-2011, 08:51 PM
Hi,
Well Its spring and time to get back to my project.

Last fall I bought a 96 Cobra that was having over heating problems. The seller told me his repair shop told him he had a blown head gasket and or a warped head. I think he had a warped mechanic. He parked the car for two years hoping to get it repaired but then decided to sell it. I bought it, put in a new battery and it amazingly started right up with the first turn of the key. Within 15 minutes it was running hot but the new radiator he had put in was cold. I ended up replacing the water pump that look brand new but had a broken impeller shaft. The car runs and drives very good now and the body is in great shape so now its onto the real challenge.

I am having electrical problems with the interior of the car. I was told the stereo didn't work, but I'm not sure if everything else worked before it was parked. The seller told me the stereo was missing but looking at it from the driverís seat the stereo looks all in tacked. I have no interior lights, no power locks & the key fob does nothing, no lights or sound in the stereo, and the odometer isnít working either.

The speedometer, tach, headlights, taillights, turn signals, and power seat all work properly. I have replaced all the fuses down by the floor in the driverís side compartment fuse panel and under the hood on the drivers side fender with no change and all the old fuses look fine.

Any suggestions? What is the proper way to diagnose electrical problems? Are there any tools or meters which will help me? Iím not sure where to start or where to go now?
Thanks,
Mike

nckissfan
04-07-2011, 10:32 PM
odometer is not electrically controlled. www.50resto.com sells replacement piece. I do not know much on electical. Good luck.

cbrown9064
04-10-2011, 01:41 PM
I would get a cheap test light and start to explore the fuse block. You can ground the clip of the test light and then (with key in desired position) test the fuse block (pull particular fuse out) for each circuit not working (seats, radio, etc...). One side of the fuse holder should have power. If so, and your fuses are good, the problem lies farther down the line. If not, power is not getting to the circuit. That would need further investigation. You may have to get a repair manual (Haynes?) that shows the wiring diagrams.

A simple way to see if you are getting power at the fuse block. Good luck!

Chris

SnowWhtSnake
04-12-2011, 09:13 PM
Thanks for your reply's

Good to know the odometer isn't electronic. Looking under the hood tonight a saw where it is going into the fire wall so I can follow that or take it apart.

I did just buy the Ford Electrical & Vacuum Mechanics Manual. Shows about everything but will take me some time to figure how to use this book.

cobrabitn
04-12-2011, 10:52 PM
Your odometer and your electrical problems are independent of one another.