PDA

View Full Version : Mysterious Squeak........Help Please


White98SVT
07-20-2002, 09:54 AM
Well lately the Cobra has been trying to tell me something is wrong but I can't figure it out. I wanted to see if you all would have any clue.

When I take off from a dead stop accelerating slowly, there's a deep squeak until I hit about 10mph then it goes away. Only at low speeds and only when I take off from a stop or a roll. Sometimes instead of a steady squeak there's breaks in the sound.

I've had people say it may be the axle bearings but I don't know. Most of the time, to me it sounds like it's coming from the front....but sometimes it sounds like it's coming from the rear. Does anyone have any ideas or how I could be sure of what it is besides taking it to Ford and paying for a diagnosis?

Thanks a lot!

cobrabitn
07-20-2002, 09:34 PM
That's kind of difficult to diagnose. I would get a friend to either drive the car or listen while you take off to see where the squeak is located. It could be a worn bushing on a strut bar or something. Once you have determined where it is coming from then I would maybe jack the car up and make the suspension compress and decompress to further your investigation. Let us know what you find out...... :cool:

White98SVT
07-21-2002, 03:26 PM
Do you think maybe it could have something to do with my struts or shocks? I have Steeda springs and I went with the Tokico Premiums for my year Cobra. I was told that they weren't valved strong enough to handle a lowered car and also that I should go with the one's for the Fox body stangs. I didn't take this information to heart but maybe I should have?

cobrabitn
07-21-2002, 08:37 PM
Stephen,

Try to single out the noise first then you will be able to tell what needs to be fixed.

cobragb
07-23-2002, 11:12 AM
I had a squeak on my 96 as you describe and it turned out to be the emergency brake cable rubbing the grommet just in front of the rear wheel. Spray some lubricant all in and around it to see if it will temporarily go away.