PDA

View Full Version : my 01 cobra is dying!! help!


jmir018
08-26-2002, 06:45 PM
well maybe not dying but its there is something seriously wrong with it....i just came back from the service department at serramonte ford. this is what they said, ",....found that bank one catalytic converter is not working and bank two oxygen sensor was slow to respond. Raised the vehicle. Found that vehicle has aftermartket exhaust system installed. the catalytic converters are also aftermarket and is not covered by the factory warranty. please be adviced that the catalyst monitors could also be switched from bank one to bank two...needs cats and 02 sensors to start."

ok..wtf?? what did i do?? how could i have messed this up? now..where can i get the "catalytic converters"?? also..why would i need cats?? i allready have bassani x-pipe w highflow cats? thank you .

willyumm
08-26-2002, 10:17 PM
Ok, first of all, it's not that bad. Your problem is the Bassani X w/cats. I had the same problem and it looks like this problem is happening all over. My computer was reset and it's been ok for now. I expect my yellow light to show " its ugly head" again. Go to your nearest Mustang speed shop and explain the issue and they will probably install the MIL Eliminators to trick the computer. Your Snake will be fine!

William

cobrabitn
08-27-2002, 11:47 AM
2001 Cobra??? Your chances are 50/50 with the MILs fixing it. You may have to go to an OR pipe or lose the Bassani cats....

Viperone
08-29-2002, 08:07 PM
OK, Unless I missed it you never said why you took it to ford. I presume it was because of a check engine light?? You need to have autozone hook the BDII up to it and give you the code. I had a PO420(I think) and reset computer a few times but it kept coming on. I then took out the K&N and put snorkel and stock air filter back on and VOILA< no yellow light for 4 weeks now. Coincidental? I don't think so......try reset and stock air filter it might help