PDA

View Full Version : Problem solved


Musio
09-09-2002, 12:26 AM
I finally solved my ticking problems whitch I traced to injectors(with help from cobrabitn, thanks Tony, and others that replied to my thread. Well looks like gas has something to do with that. First time I filled up my cobra about a week ago at Esso gas station soon after car developed ticking sound, I thought that maybe I pushed the car to hard or something. So I decieded to try a different gas station this time I went to Shell, fair enogh the noise is gone. By the way I live in Canada. Hope it works for others with this problem. Good luck!!!

smashedheadcat
09-09-2002, 12:47 AM
Congratulations on solving the problem. I would'a chimed in, but honestly didn't have any information that would've helped you. I'm looking to solve my car's problem tomarrow. (order parts anyway)

Stavesacre21
06-18-2005, 02:09 AM
Another question from way back in the day, but i've gotta ask...

...would better gas, at a place like Shell, honestly be able to cause the engine to quiet down in any way? I'm just curious, cause i'm starting to get an engine tick at only 44K. I'm a little concerned about something like this starting up this early in the engine's life...just as any Cobra owner, i'm concerned for the car's outlook!

Thanx guys!

Musio
06-23-2005, 10:03 PM
First you gotta determine if its the engine tick or injectors, I was worried as well, but it turned out that injectrors were making the noise. From what I've heard and read aluminium block and heads just make it louder. Try better gas, it worked for me.

cobrabitn
06-23-2005, 11:34 PM
Glad you got the problem fixed! :thumbsup: