PDA

View Full Version : supercharger belt ka-boom


corrosive
09-04-2003, 09:04 PM
whats up guys,

i'm running a vortech supercharger w/intercooler. i've had the
charger on for about 1500 miles. and i just blew the belt. has
anybody ran into this situation. note: when i ran on the dyno
w/ the supercharger being about 300 miles old. the dyno was
only reading a top of 8 pds boost . the system is rated at 10.5 pds. if anybody has any coments. it would be greartly appreciated. i think i'm going to have to call vortech to see if they have some type of fix for this slippage or something.

tcrews
09-04-2003, 09:16 PM
Largest problem I've seen that typically causes this is an alignment issue. We uses some small spacers on the bracket to make sure the pulleys were all perfectly lined up.

Also the tensioner pulley could be bent/damaged and is allowing too much slack in the belt allowing it to slip.

Check those two items and see what's up.

I have 16psi on my vortech with zero belt slippage/issues.

Big Daddy
09-04-2003, 09:58 PM
Tom is right on as usual I'm only seeing about 10lbs of boost when I should be getting 14-16 lbs. True Blue is going to change out the tensioner and put a smaller belt on tomorrow along with checking the alignment of the pulley's.

corrosive
09-04-2003, 11:51 PM
has anybody tried this special pulley from
www.reichardracing.com. for vortech superchargers.
just wondering.

smashedheadcat
09-06-2003, 02:24 AM
In my opinion, the vortech idler pulley is junk. It should be designed differently or something ;). I've been working on shimming my bracket out for months now. I finally got it to where if I throw a belt, it doesn't damage the idler pulley anymore. Also, I did have a problem throwing belts and it was due to the factory tensioner. I replaced mine with the steel version (looks the same, but black). It's supposed to put more tension on the belt, and also resist bending (I bent my stock tensioner somehow).

Also, from what I've heard, the RR Racing pulleys are great pieces.

redsnake99
09-06-2003, 10:53 AM
I've had similar experience with the idler pulley from Vortech. Mine has been replaced and all is fine. I have over 60,000 miles with my Vortech S2 in place. I'm running a safe 8 lb. of boost and have readings of 489 RWHP.

Electrical gremlins have struck again. If they ever finish fixing Big Daddy's car, then they can get to mine.

:doubt:

Big Daddy
09-06-2003, 01:01 PM
Originally posted by redsnake99
Electrical gremlins have struck again. If they ever finish fixing Big Daddy's car, then they can get to mine.

:doubt:

Well guess why I was back down at TB yesterday....BELT SLIPPAGE! They put a new tensioner on and a smaller belt and now I'm up to about 12lbs of boost but I know I should be making more boost than that! SO I'm going to order the RR pulley for the car and another smaller belt! I'm not going to stop until I see at LEAST 14lbs of boost! :D :D :thumbsup:

itsrlong
09-07-2003, 09:02 PM
Who makes this "steel" replacement tensioner? Is it an automatic tensioner also? I was having the same problem with my Procharger D-1SC so I have ordered a couple of Reichard's pulleys.... I will let everyone know how much they help.

Thanks