PDA

View Full Version : supercharger


boostedstang
11-30-2003, 08:00 PM
My supercharge is leaking or shouting out out. It is coming out were the intake is and my car is sucking it up into the motor. Any ideal why it is doing that? It is a 99 cobra with a SQ supercharger.

smashedheadcat
11-30-2003, 09:28 PM
If you pull the inlet to the blower off, is there right on the inlet to the supercharger. If so, oil is probably coming from a seal inside the blower. I had oil there, and it turns out I was pulling just a tad amount from the valve cover under some heavy boost. It was just a little wet from the front of the s/c, to the hose that goes to the valve cover. If it's the supercharger, I think Vortech rebuilds them for $150-300 range. Not sure though. Heck, it may be covered under warranty.

redsnake99
12-01-2003, 12:03 AM
The charger has a warranty, like for 3oK miles, then it may need a rebuild from Vortech. They replace seals, repair any parts that might need it. for about what he said. Problem is, your car is inoperable while that happens. Mine has had that done once. My Vortech went on the car at 28K miles. This was done with 65K mile. Car now has 96K miles.

:D

boostedstang
12-01-2003, 07:10 PM
Ya that is the problem it is like my oil pan move up the the supercharger. It was put on 03-02-2002. I thought vortech has a standard 3 year warranty or at leat that what they say on their web sight. If I do have to have it rebuilt who do I send it to. Atlanta Chassis Dyno are the people that installed it can I just take it back to them or do I send it to vortech them self. Also smashedheadcat you said your did this under heavy boost. I am runnign 8 psi. If I am having the same problem you are how did you fix it? thanks for the help

boostedstang
12-02-2003, 07:42 PM
Do any of ya vent you value cover into the atomsphere insend of the way vortech tell you to?

smashedheadcat
12-03-2003, 12:38 PM
Originally posted by boostedstang
Ya that is the problem it is like my oil pan move up the the supercharger. It was put on 03-02-2002. I thought vortech has a standard 3 year warranty or at leat that what they say on their web sight. If I do have to have it rebuilt who do I send it to. Atlanta Chassis Dyno are the people that installed it can I just take it back to them or do I send it to vortech them self. Also smashedheadcat you said your did this under heavy boost. I am runnign 8 psi. If I am having the same problem you are how did you fix it? thanks for the help

My "heavy boost" should have been, heavy throttle. I was seeing 10-12 psi originally, but after i lowered compression, ported heads/intake and opened the exaust up, i'm down to 6psi. Even now, I can still get some to come out through it, but i'm talking very little. (won't see any difference in oil level) I don't vent mine to the atmosphere, but I wouldn't mind doing it....... I'd have to look into it and see if there's any benefit to it.

smashedheadcat
12-03-2003, 12:38 PM
BTW, you'd send it to vortech. Call them up, and tell them what your problem is (oil coming from blower), and they'll tell ya what to do from there.

Josh

boostedstang
12-04-2003, 09:43 PM
I did he was like sound like it blown. I was just wonder if at is a better set up venting it into the atomsphere. That is how I did my Twin turbo 5.0 to stop the PVC from coming out the back.