PDA

View Full Version : Tale of two mustangs


jkrkk1
05-20-2004, 12:32 AM
I had a 94 GT conv. w/125K miles until recently, I sold it to a friend of mine and bought a 95 Cobra conv. w/62K miles. I thought that my cobra was a little sluggish so I drove the GT, 25 H.P. less. The GT is definately quicker, better throttle response. I have done the same things to bothcars, K & N air filter, plugs, distributor and rotor, pcv, cleaned out the throttle body, both have 3.08 gears. When sitting at an idle, both have a slight hesitation when you mash the gas, the cobra is a little bit more though. The cobra acts like a car with a turbo, it's like it has to wind up then it goes. Both cars were very well taken care of. Any suggestions.
thanks and God Bless
jeff

cobrapace94
05-20-2004, 12:40 PM
Have you check for codes in the Cobra? They can be stored and not make the check engine light come on.
Are the O2's original? If original, then might want to change them, only 2 no matter what the parts store says. Also, if the car has a KN the oil can get on the MAF meter and coat the wires causing false readings. Pull you MAF meter out and clean the 2 small wires inside, be very careful & use something that does not leave a residue like alcohol (not the kind you drink) or some contact cleaner. To get to it you have to remove it from the car and take apart the box right behind the filter.
What is the timing at? Might bump it up a little, if it starts to ping, back it down a few degrees. I have mine at 13-14.

jkrkk1
05-20-2004, 02:48 PM
Dummy here, are the O2's, oxygen sensors, and where do they go? I cleaned out the MAF with break cleaner. What should the fuel pressure be at the fuel rale? How can I tell if one or some of the injectors are clogged? Any suggestions would be helpful. I've had several mustangs over the years, but this one is the nicest, except for performance wise.
thanks and God Bless
jeff

cobrapace94
05-20-2004, 03:57 PM
Yes the O2's are the oxeygen sensore. They are under the car just behind the headers. I don't know what fuel pressure should be, I assume you have a adjustable fuel regulator.
Do you still have the stock mid pipe, cats? They could be clogged, good reason to upgrade (what I tell the wify:) ).
Check out the balencer when you check the timing, the 94\95's have a history of the rubber comming out and slipping causing the timing marks to be off. If it comes apart, then that would be baddd.

jkrkk1
05-20-2004, 10:40 PM
You were correct, they told me there were 4 O2 sensors, 2 in front of the catalytic conv. and 2 behind. I think I've got the timing at 16 with not ping, I'll bring it back a little. How can you tell if injectors might be clogged? Can they be cleaned out, $60 a piece is pricy to me. I'm going to change the fuel filter tonight, maybe it is clogged. Fuel pressure at the rail is supposed to be 35-40.
thanks and God Bless
jeff