PDA

View Full Version : Window problems


Carl G
06-13-2004, 12:16 PM
Driver side window want go back up, Had this exact problem with the 02 GT. I just makes a clicking sound. I dont think it is the motor. Anyone else have this problem and suggestion on how to fix. Remember no warranty anymore :(

msmap
06-13-2004, 12:20 PM
maybe this might help ya out :thumbsup:

http://svtperformance.com/forums/showthread.php?s=&threadid=102234&highlight=window+wont+go+up

cobrapace94
06-13-2004, 12:41 PM
No warranty on interior??? How did modding the motor mess up the power window?
I heard there is a plastic gear that strips out, usually on older cars like mine. Not sure after that. The link Sherri posted is good info. Just tear into it & see what happens?
Good luck

03 cobra toy
06-13-2004, 12:55 PM
Driver side window want go back up, Had this exact problem with the 02 GT. I just makes a clicking sound. I dont think it is the motor. Anyone else have this problem and suggestion on how to fix. Remember no warranty anymore :(

"No warranty" is only on the drive train....you should be able to get it fixed under warranty...

jimmysidecarr
06-13-2004, 04:28 PM
maybe this might help ya out :thumbsup:

http://svtperformance.com/forums/showthread.php?s=&threadid=102234&highlight=window+wont+go+up
SCROLL DOWN TO THE pics, and description...
Excellent link!!!

If the plastic absorbers(roller looking things) have crushed/crumbled... You can..... (And alot of guys at work have In thier own or friends cars)... replace them with steel nuts, the same diameter... Only down side is slightly more noise.... Nice cheap fix!

Good luck!!!
Jimmy :thumbsup:

Topless In Tex
06-14-2004, 12:45 AM
Ive been dealing w/ this on my Stang for MONTHS now! we have fixed my drivers side 4 damn times, and it keeps breaking! And it ALWAYS breaks, when the friggin' window is stuck DOWN in major storms!! Last 2 times its been a dead spot in the motor. My passenger side is messed up too, have to pull or push on the window to make it move. My drivers side has been the biggest pita that I have ever seen! This is a temporary fix, I am sure, till we hit that dead spot again......
All I can say, is good luck. Ive now got about a 9 X 4 inch bunch of FOAM exposed thru my leather seat, and my butt stays wet most the time. Floor boards are prolly rusted out by now. Wish I had an easy answer for you...
Best of luck to you!
:banana:TNT:banana:

Dano
06-15-2004, 07:13 PM
What jimmysidecarr said about the "steel nuts" is right on. I recently repaired my driver's window motor. The plastic balls (bearings) inside the motor were completely gone ... looked like bread crumbs.
Your setup may be different, but go to this Web Page of mine and read the write-up - it could save you a LOT of money (unless it's a covered item, then I wouldn't even mess with it - let Ford fix it. Here's the address to that page of mine:

http://users2.ev1.net/~w8368/wmotor.htm

here's one of my photos:

http://users2.ev1.net/~w8368/wmot2a.jpg


Dan

Topless In Tex
06-29-2004, 01:51 AM
We ended up replacing BOTH motors on both sides this weekend. Like Dano said, the pass. side was wasted, looked like bread crumbs... and there was a dead spot in the drivers side. They are both working like a champ now, except now the switch on my pass. side is not working....uggh.
Got the motors at Orielys or Hi-Lo. Forget which one. Ran about $130 for both.
:banana:TNT:banana:

Dano
06-29-2004, 06:20 AM
This is kind of simple sounding, but you need to make sure the elect door lock connector inside the door panel was reconnected. I tried to ops check mine, with the door panel just hanging there, and it wouldn't work unless I had the elect door lock connector hooked-up. If both of your door locks ARE working, must be the switch (or the connector going to the motor - or the connector going to the switch assembly).

Sure a lot of trouble to be having. :eek:


Dan

http://users2.ev1.net/~w8368/must2.htm