PDA

View Full Version : 03 stalling


crunchit
10-26-2004, 12:27 AM
This just began this morning. Everytime I would throw it into neutral before stopping my rpm's would fall below 5k and I would stall. It happened several times today. It seems if i gently apply pressure to the brake, the rpms do not drop so low. has anyone experienced an unusual stall? I have stalled a few times this year, usually when downshifting and decreasing speed rapidly to a stop. I thought nothing of it until now. The only mod I have made is the K&N cold-air system. I disconnected the negative cabel from my battery on install when disconnecting the mass air sensor. So I don't think that's the problem. the only difference lately is the change in temperature outside. We are in the fall here in NY.

Any ideas?

Lthl Venom 03
10-26-2004, 12:44 AM
yeah that can become a huge problem. It'll only get worse. Ford has a fix for it so take it back to the dealer and they'll fix it for you. They have to flash your computer. I had a big problem with this too but haven't had it happen a single time since the flash. Having your car die in the middle of a turn can be pretty scary! :eek:

jack
10-26-2004, 12:45 AM
I have not had that happen but i would start with the simple stuff first. Check your connections on the maf sensor then i always check vacuum lines for cracks or leaks. Usually poor idle is caused by lack of vacuum. What little bit i know about hydroboost, it shouldnt have anything to do with the idle. Hope this helps

Firme
10-26-2004, 01:52 AM
I had to dig this up from a previous post of mine.

FYI, this is a gremlin that people have had since 1999, and there is a fix.

It happened to me twice in my 2001 with no modifications to my intake, and went away after a reflash. Its a flash program bug/flaw

Yours is a 2003 . You can get the dealer to reflash the PCM under warranty. A tuner can also fix this for you. It is a common issue.

Basically you need the "stall reflash", which changes the setting for the idle air bypass solenoid.

P.S. if you take it to ford, the official fix of the stall reflash is # SSM-17542, that is what they can look up if they don't know what you are talking about .

I know, the computer controlled cars throw people curve balls... :)

Mirage
10-26-2004, 07:55 AM
crunchit~ As Firme mentioned, this is a common issue (one which I also experienced :mad: ) but was fixed by the dealer re-flashing the computer. Thankfully this little gremlin has not reared its ugly head since then.

crunchit
10-26-2004, 09:12 PM
Guys, you won't believe this...I dropped my car off this morning at ford and received a call two hours later informing me that my K&N air filter fell off! How could I have not seen that when I briefly checked my MAS last night?


Must have been a long day at work...

thanks for all the advice!

Big T
10-27-2004, 12:19 AM
I have had some stall problems also. If I bring it to the dealer for the reflash, will it screw up my tune that is installed from my SCT flash tuner?

ausie
10-27-2004, 07:48 AM
hmm, that brings back memories of my 01. It stalled when using a high flow air filter. I had it into ford and they told me the car is working fine and they could not detect an issue. That was sometime last year, they did not re-flash the ECU. Had I known that sooner.... :eek:

scocher
10-27-2004, 08:50 PM
Wow! :eek: I'm glad I read this thread! My 03 has stalled out on me a few times. Mine happened when stopping on an incline. Although, I don't wish any problems on anyone else. I'm glad to know that it's not just me. I'll have to call my dealership and check into the fix. Thanks a bunch, guys! :thumbsup: