PDA

View Full Version : New owner, few questions


Bluedot_26
11-10-2004, 01:01 PM
Took delivery of my new 2004 coupe a week ago and within 4 days wondered why it started to idle roughly and smell like skunk.

A quick search here diagnosed the problem as likely a plugged cat (I haven't looked for discoloration yet) - very handy, thanks much to SCMC forums and FAQs.

After speaking with the dealership, the advisor conceeded that based on my description that it was likely the problem, however it seems that it may take several weeks (or longer) to obtain replacements.... sigh

Have others with the same problem getting new cats ? I'm half tempted to just buy aftermarket ..

Otherwise very happy with the car, much more than I expected and a far cry from my previous mustang (88 LX 5.0) ...

Firme
11-10-2004, 01:23 PM
Welcome to the board and Sorry to hear about your problem. If you plan on modifying the car, it might be better to just install an aftermarket midpipe, and take delivery of the stock replacement and store it away.........

crunchit
11-10-2004, 01:43 PM
Welcome to the board.

Big Daddy
11-10-2004, 02:24 PM
What Firme said! Get a good aftermarket mid pipe and cats and store the stock stuff! :thumbsup:

cobrabitn
11-10-2004, 08:39 PM
Hey Crunchit,

I used to live in Queens!

:)

Big T
11-10-2004, 09:41 PM
I had similar symptoms initially. All types of strange smells (skunk like) especially upon starting. I don't drive mine much but it did dissapear after about two months. Although the stock exhaust did not last long after that anyway. It was too quiet for me.

ausie
11-12-2004, 06:41 AM
yikes, I can only hope that the plugged cats were a manufacturing flaw and not a mechanical one. Oil burning and or coolant burning will destroy cats. Burning oil will be more dramatic on the ceramic core of the cat than would be the case with the coolant.

I would opt for the aftermarket mid pipe and save the factory stuff for later, i.e. inspection time if emmisssions are required.