PDA

View Full Version : Got my pully upgrade and Dyno Tune today


crunchit
04-21-2005, 07:52 PM
What a great day. Got to mod the car and meet some other cobra owners and mustang enthusiasts. Best of all I was pleased with the dyno results. They went 5 runs. My first run went 470, 2nd 479 and stayed up around there (477-479) but was running lean. Finally he got it down and we leveled off at 477.9 and 511 lbs torque. They were pretty impressed as well. While I was there we threw in a Steeda shifter (how did I ever live so long without it?) and I would have installed the MAC exhuast (yup i'm removing the SLP, anyone interested? pm me) but we ran out of time. Next week!

Now on to the suspension and stabilizing my rear end.

Dave B.
04-21-2005, 10:50 PM
please tell me,
did you use a predator? or what did you use to set it with?

If you did use a predator type device, and started with it set for pulley tune, how lean was it and where abouts on the RPM range ??

cobracrazy
04-21-2005, 11:26 PM
More importantly... How did the drive home feel? :bounce:

Dave B.
04-21-2005, 11:42 PM
and,,,,,,,,,where did they set the air/fuel ratio??
is it the same through out the rpm band?

ausie
04-22-2005, 07:50 AM
Nice numbers:thumbsup:

I know the SLP can be ear piercing once you install it (the kit without the mufflers that is, since the resonators are just hollow expansion areas). It was much louder in the 04 than the on the 01. More than likely due to different flow rates in the heads (not to mention the blower). It took longer for the cat-back to season itself (at first it was so loud I did not like it but I knew it would become more compliant to my ears sooner since I had the same experience with my 01) . Now I can barely hear it all that much (not due to loss of hearing). I would probably not like it all that much if I had a convertable and I am sure the x-pipe makes it worse (one reason why the stock H pipe is still in place). I am not sure what I would go with if I did not like it. I could always opt for the 01 exhaust which I still have down in my basement (which I think was better in sound quality than the stock 04). Bassani comes to mind as well as the Borla exhaust. If you go with MAC, get the stainless if offered.

crunchit
04-22-2005, 09:16 PM
please tell me,
did you use a predator? or what did you use to set it with?

If you did use a predator type device, and started with it set for pulley tune, how lean was it and where abouts on the RPM range ??
Sorry it took me so long to respond, had to call the tech. Here's is what I found. I am not good with this technical stuff so please excuse me if I get something skewed.

No, we didn't use the predator. We did a custom tune. Early in the run with a sniffer we were running lean in the high 12's. My car turned out to be an absolute torque monster. It was producing so much torque that we had to do five pulls to fatten it up and get it down into the 11's which resulted my numbers listed below. He also mentioned something about 22-22.5 degrees, which i think had something to do with the air to fuel ratio? I am gonna go over it again tomorrow when I change my exhaust.

I found out a few other things about my 03 as well. They showed me that where my manifold is it's painted blue. They said that it was an indicator that my car was a late build (which mine was built in may 03). The tic they had with early builds was corrected and they did this to identify the second run in production. So essentially it's the same as the 04, but what made it a bit faster than the 04 is that they put restrictive cats on the 04, which weren't done in 03.

It was definitely a fun day. Got to hang out with Jimmy Vaccaro and went for a spin in his stroker 04 mach1. What a sleeper and an automatic!

Cobracrazy ~ the ride home was like I just pruchased a new car. I can't wait to install a quieter exhaust tomorrow so I can hear that supercharger scream!:thumbsup:

Steve

ausie
04-24-2005, 01:02 PM
Steve, you are correct about the blue dot or blue paint on the heads. The early 03 Cobras used the same casting (not 100% certain on that) from the 99/01 which had issues with cooling passages and flow rates due to low floor design and over-run of the intake valves which caused valve overheat conditions (tick or ping are they one and the same?). I am uncertain if the early 03's had the same cam profile. I do know that the Cam profile was changed when they upgraded the head design which started in the late 03 build which is classified as the 04 heads. In fact, the 04 heads out perform or at least match that of the Cobra R heads. Rest assured, the blue paint indicates you have one of the best 4.6L heads on the market and was used to identify the changes from the early production of the 03 motors. :thumbsup:

sonicblu
04-29-2005, 11:13 PM
:eek: just exactly where is the blue paint at,mine was built in may 03 as well.

ausie
04-30-2005, 12:39 PM
That is a good question Sonicblu. When I heard about the paint (blue dot) I went looking for it even though I have an 04 model I was curious to see if it was there if at all. Perhaps it does not pertain to mine since the VIN number may indicate the fix as well as the model year. It should be located on the drivers side head, but where?

crunchit
04-30-2005, 04:51 PM
Here you go...

http://img.photobucket.com/albums/v482/crunchit/temp05003.jpg

http://img.photobucket.com/albums/v482/crunchit/temp05002.jpg

http://img.photobucket.com/albums/v482/crunchit/temp05001.jpg

Please excuse my untidy engine. It's been raining every other day here...:rolleyes:

steve