SCMC Message Forum

SCMC Message Forum (http://www.svtcobraclub.com/forums/index.php)
-   SVT Cobra R (http://www.svtcobraclub.com/forums/forumdisplay.php?f=8)
-   -   clutch screeching noise?? (http://www.svtcobraclub.com/forums/showthread.php?t=918)

Andy M 11-12-2001 11:24 AM

clutch screeching noise??
 
Guys,

I am getting a very irritating screeching noise at idle on the R, mostly noticable after the engine warms up and I have driven for a few miles or so?

If I come to a complete stop, but leave my clutch pedal depressed (like at a red light) you hear the squeeling noise - very similar to a fan belt, in fact this is what I thought it was.

Any ideas as to what this is? is this an indication that my clutch is about to blow? it does not seem to be slipping or anything? I don't ride it hard, I don't do hard launches... Could this be just the springs which hold the pressure plate on? or something obscure like that?

any ideas?

kevin 11-12-2001 11:37 AM

doesn't sound to me like anything i'd recognize.

i wonder if the engine bay cleaning did something to a belt that shows up at loe speeds?

Andy M 11-12-2001 11:48 AM

Quote:

Originally posted by kevin
doesn't sound to me like anything i'd recognize.

i wonder if the engine bay cleaning did something to a belt that shows up at loe speeds?

Kevin,

I didn't wet the engine bay. Just used a cloth with some engine silicone cleaner spray on it to wipe down all of the surfaces. Actually, this noise started a few days earlier.

I dunno? I need to schedule to bring it to Kenny B anyway to install the new IRS brace I bought from Paul's Performance, so I'll have em check this out also? IO hope it is nothing serious? So far, it seems to be just a noise... the clutch seems to be working just fine?

Dean95CobraR 11-12-2001 11:55 AM

Almost sounds like a throw out bearing. :confused:

Andy M 11-14-2001 03:27 PM

I talked to Kenny Bumbera today and will be bringing the R to him early next week. He seems to also think it may be the throw-out bearing?

Work to be done includes:

1) clutch issue??
2) install Paul's Performance IRS brace
3) drain brake fluid, install braided lines, replace fluid, check rotors!!

GTIronman 07-11-2002 01:36 PM

Your problem sounds identical to the one I had repaired on a 2001 Cobra, even with it not appearing until the car warms up. It will go away if the clutch is released. I'll have to review the repair records to see exactly what was repaired in the clutch assembly, but I know a throw out bearing was discussed.

The reason I'm really interested is, a month later, I'm getting the same noise. I'd like to find out if this is a Cobra issue in general or if I just have a lemon in the clutch.

I'll write back next week with the details.

Andy M 07-11-2002 01:52 PM

Quote:

Originally posted by GTIronman
Your problem sounds identical to the one I had repaired on a 2001 Cobra, even with it not appearing until the car warms up. It will go away if the clutch is released. I'll have to review the repair records to see exactly what was repaired in the clutch assembly, but I know a throw out bearing was discussed.

The reason I'm really interested is, a month later, I'm getting the same noise. I'd like to find out if this is a Cobra issue in general or if I just have a lemon in the clutch.

I'll write back next week with the details.

It ended up being the throwout bearing. I installed a new (much stronger dual kevlar Viper clutch and bearing) at the time, and even after some pretty hard track days since this time, all is well. Got the clutch from Apex Motorsports in CA.


All times are GMT -4. The time now is 02:09 AM.

Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 1999-2017 SCMC, Inc