View Single Post
Old 08-05-2011, 02:30 AM   #1
Spiney
Registered User
 
Join Date: Jul 2011
Location: Reading PA
Posts: 11
Question 96 SVT Cobra Tuner Chip ECM questions ?

My new to me 96 SVT Cobra 39K Miles runs great 90% of the time and erratic enough to cause me worry and needs to be fixed. It will stall from idle and tonight after about an 80 mile ride it started sputtering and missing. All gauges were 100% normal. When I came to an intersection the Revs would run up to 2000 on their own in neutral. I received some answers from the net that it could be the tuner chip going flakey. That sometimes the contacts corrode. Or it could be the ECM. So Where do I find the Chip?
The previous owner said it was a "Super Chip" can anyone tell me the MFG of that?

Mods include no cats, Flowmaster mufflers, new H pipe and K&N cold air kit. If I pull the chip will car revert to factory tune. Will it run with these mods? If I need an ECM can I buy a refurb? If I buy refurb or used must it be a 96 Cobra ECM? My first thought is to pull the chip, clean the contacts, and re-seat it.

I guess that covers it. I'm not familiar with chips. I'm an old school Holley Double Pump guy. Thanks, Spiney-Dave
__________________
1996 SVT Cobra Blk / Blk 39K miles.

245 40ZR 17 Firehawk tires mounted on Ford Racing Cobra 17 X 9 chrome wheels, Super Chip, Flowmaster H pipe w/3 chambers and stainless steel tips, B&M short throw shifter, K&N air filter system, Optimal Red Top battery,Hawk performance brake pads. Have all original parts

Previous Stangs in order. 67 CP 6 Cyl 3 Spd, 68 Cp 6 Cyl Auto, 70 FB 302 4V Auto, 82 GT 5.0 HO T-Top 5spd TRX, 70 Mach-1 351-C 780 Holley, Hurst 4 spd Louvers, all purchased cheap except 82 GT purchased new. Very sorry I no longer own them especially the Mach-1.
Spiney is offline   Reply With Quote