SCMC Message Forum  
Go Back   SCMC Message Forum > SVT Platforms > 93 - 95 SVT Cobra Forum
User Name
Password

Register FAQ Members List SCMC Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread
Old 06-21-2006, 02:11 PM   #1
Eric_red94
Registered User
 
Eric_red94's Avatar
 
Join Date: Mar 2006
Location: Whiteland, IN
Posts: 47
94 cobra electrical problems

My cobra is bogging hard and falling on it's face periodically. It has an msd coil and msd 6al ignitinon, 80mm mass air. The problem seems to be ignition related, it is vortec supercharged and a 331. When it bogs, the tach jumps all around like it is on crack. Leading me to think it is electrical related to the tach, maybe the coil, etc. Any advice would be appreciated. Thanks

Eric
Eric_red94 is offline   Reply With Quote
Old 06-21-2006, 04:50 PM   #2
venomous
Polk County Redneck
 
venomous's Avatar
 
Join Date: Feb 2003
Location: Polk County, NC
Posts: 557
Send a message via AIM to venomous Send a message via Yahoo to venomous
I have heard of people having probs with MSD ignitions. Try switching back to the stock ignition and see if that helps. Maybe the coil as well try the stock one.
__________________
~1995 "Rio Red" Cobra #3379 of 4005
2.2 Kenne Bell Blowzilla/ Flowzilla Supercharger (12# Boost), AFR 165 Aluminum Heads 61cc, TMoss Port Matched Cobra Lower, Trickflow 1.7 Roller Rockers, Crane 2031 Camshaft, 3/8" Intake Spacer, 60# Injectors, Accufab 75mm Throttle Body w/ Blank Spacer, DynoJet Wideband Commander, MSD Pro Billet Distributor, MSD Blaster Coil, SCT Big Mouth Meter BAF 2400, JLT Custom Cold Air intake, Deleted EGR/ Smog, Mac Chrome Radiator Pipes, Mac Ceramic Coated Shorty Headers, Mac O/R H-Pipe, Flowmaster Cat-Back, Pro 5.0 Shifter, Ford Racing 3:73 Gears, H&R Sport Springs, Chrome Cobra R Wheels
Pro Dyno Tuned to 498 RWHP 497 RWTQ
venomous is offline   Reply With Quote
Old 06-22-2006, 07:51 AM   #3
TL04SVT
Registered User
 
TL04SVT's Avatar
 
Join Date: Oct 2004
Location: Belmont, NC
Posts: 74
Ive also heard about msd having problems.... my 93 had the same symptoms yours does... the tach would jump all over. I replaced the distributor with a stock remanufactured one and the problem went away. I would say its either your ign. control mod or stator.
TL04SVT is offline   Reply With Quote
Old 06-22-2006, 11:28 AM   #4
Eric_red94
Registered User
 
Eric_red94's Avatar
 
Join Date: Mar 2006
Location: Whiteland, IN
Posts: 47
thanks guys

Probably will change out the coil, distributor and maybe trash the ignition. Appreciatte the help!

Eric
Eric_red94 is offline   Reply With Quote
Old 06-26-2006, 10:10 AM   #5
Eric_red94
Registered User
 
Eric_red94's Avatar
 
Join Date: Mar 2006
Location: Whiteland, IN
Posts: 47
power pipe off

looks like my problem was the Anderson Ford MS power pipe falling off the back of the vortech again. I can't keep it on there more than a few runs, stupid thing. It seems to be a bad design, or just a pain in the but.

Eric
Eric_red94 is offline   Reply With Quote
Old 06-26-2006, 10:28 AM   #6
venomous
Polk County Redneck
 
venomous's Avatar
 
Join Date: Feb 2003
Location: Polk County, NC
Posts: 557
Send a message via AIM to venomous Send a message via Yahoo to venomous
Glad to see you got it fixed! When I first got my JLT intake it kept coming off the TB and till got me a better clamp and it stayed.
__________________
~1995 "Rio Red" Cobra #3379 of 4005
2.2 Kenne Bell Blowzilla/ Flowzilla Supercharger (12# Boost), AFR 165 Aluminum Heads 61cc, TMoss Port Matched Cobra Lower, Trickflow 1.7 Roller Rockers, Crane 2031 Camshaft, 3/8" Intake Spacer, 60# Injectors, Accufab 75mm Throttle Body w/ Blank Spacer, DynoJet Wideband Commander, MSD Pro Billet Distributor, MSD Blaster Coil, SCT Big Mouth Meter BAF 2400, JLT Custom Cold Air intake, Deleted EGR/ Smog, Mac Chrome Radiator Pipes, Mac Ceramic Coated Shorty Headers, Mac O/R H-Pipe, Flowmaster Cat-Back, Pro 5.0 Shifter, Ford Racing 3:73 Gears, H&R Sport Springs, Chrome Cobra R Wheels
Pro Dyno Tuned to 498 RWHP 497 RWTQ
venomous is offline   Reply With Quote
Old 06-26-2006, 04:21 PM   #7
Eric_red94
Registered User
 
Eric_red94's Avatar
 
Join Date: Mar 2006
Location: Whiteland, IN
Posts: 47
yep new problem

I got the pipe on good and promptly went out and blew a head gasket. Guess those o-rings and lockwires on the afr185 heads only last a few months.
Tear it down and put it back together again. Seems to be a recurring theme with forced induction. Pay to play. Had a really safe tune, too. Odd.

Eric
Eric_red94 is offline   Reply With Quote
Old 06-26-2006, 05:47 PM   #8
venomous
Polk County Redneck
 
venomous's Avatar
 
Join Date: Feb 2003
Location: Polk County, NC
Posts: 557
Send a message via AIM to venomous Send a message via Yahoo to venomous
What type head gaskets did you use? Cometic heads gaskets are really stout and take alot of abuse.
__________________
~1995 "Rio Red" Cobra #3379 of 4005
2.2 Kenne Bell Blowzilla/ Flowzilla Supercharger (12# Boost), AFR 165 Aluminum Heads 61cc, TMoss Port Matched Cobra Lower, Trickflow 1.7 Roller Rockers, Crane 2031 Camshaft, 3/8" Intake Spacer, 60# Injectors, Accufab 75mm Throttle Body w/ Blank Spacer, DynoJet Wideband Commander, MSD Pro Billet Distributor, MSD Blaster Coil, SCT Big Mouth Meter BAF 2400, JLT Custom Cold Air intake, Deleted EGR/ Smog, Mac Chrome Radiator Pipes, Mac Ceramic Coated Shorty Headers, Mac O/R H-Pipe, Flowmaster Cat-Back, Pro 5.0 Shifter, Ford Racing 3:73 Gears, H&R Sport Springs, Chrome Cobra R Wheels
Pro Dyno Tuned to 498 RWHP 497 RWTQ
venomous is offline   Reply With Quote
Old 06-27-2006, 10:29 AM   #9
Eric_red94
Registered User
 
Eric_red94's Avatar
 
Join Date: Mar 2006
Location: Whiteland, IN
Posts: 47
no problem now

Apparentlly didn't blow a gasket, something caused the car to overheat, fan, thermostat, vapor lock? Any how went out last night and ran the dog chit out of it and it is fine. Probably race it tonight. Got that power pipe on good now.

Eric
Eric_red94 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 11:45 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 1999-2017 SCMC, Inc