SCMC Message Forum  
Go Back   SCMC Message Forum > SVT Platforms > 96 - 01 SVT Cobra Forum
User Name
Password

Register FAQ Members List SCMC Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread
Old 08-29-2006, 01:58 PM   #1
99cobra~
Registered User
 
Join Date: Jun 2006
Posts: 58
Clutch?

Hey guys... I had my first problem with my cobra last night... I was beating on her some and I went into second and there was nothing. I pulled over and no gears work not even reverse. I put the car into gear and it can be pushed forward. I think its the clutch? any ways to check before I order parts? also is my clutch hydralic? I really hope I didn't blow my tranny.. otherwise I might have to say bye to my cobra..
__________________
99' Cobra "Y TRY"
MGW shifter and race knob --A++
Stainless Steel X-pipe
02 Sims
BBK Cold Air

95' 5.0 GT
X-pipe (no cats)
MAC Cold Air
Underdrive pullies
Diablo Sport 2 Chip
99cobra~ is offline   Reply With Quote
Old 09-13-2006, 03:33 PM   #2
cobra9915svt
Registered User
 
cobra9915svt's Avatar
 
Join Date: Sep 2006
Location: Detroit, MI
Posts: 10
I had a similar problem with my 99. I was in the middle of a burnout in a parking garage, and when I hit second I had nothing. It ended up getting towed to the nearest Ford dealership where I received the bad news. The transmission, whichi I thought was blown, was actually in good shape. I had blown the engine. I'm sure you'd know if thats what It was.


Also on a second occasion I was driving hard in first, hit second and again had nothing. This time I had blown out the rear differential gear. Just a couple of things to check.
cobra9915svt is offline   Reply With Quote
Old 09-13-2006, 04:15 PM   #3
03slidewayzSVT
Registered User
 
03slidewayzSVT's Avatar
 
Join Date: Oct 2005
Location: Kannapolis, NC
Posts: 475
Send a message via AIM to 03slidewayzSVT
Could have broke the input shaft between the engine and tranny.....something else to look at...
__________________










03slidewayzSVT is offline   Reply With Quote
Old 09-16-2006, 08:28 PM   #4
99cobra~
Registered User
 
Join Date: Jun 2006
Posts: 58
Quote:
Originally Posted by 03slidewayzSVT
Could have broke the input shaft between the engine and tranny.....something else to look at...
took it apart this afternoon at my brothers shop and sure enough the imput shaft is in 2 pieces..

can I order a stronger one from somewhere?? He said he could probably get a heat treated one that is better than fords OEM one. Any idea how hard it is to change the imput shaft? or how much it is going to cost? because my brother doesn't really like working with transmissions all that much.
__________________
99' Cobra "Y TRY"
MGW shifter and race knob --A++
Stainless Steel X-pipe
02 Sims
BBK Cold Air

95' 5.0 GT
X-pipe (no cats)
MAC Cold Air
Underdrive pullies
Diablo Sport 2 Chip
99cobra~ is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 12:14 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 1999-2017 SCMC, Inc