SCMC Message Forum  
Go Back   SCMC Message Forum > SVT Platforms > '03-'04 Cobra Forum
User Name
Password

Register FAQ Members List SCMC Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread
Old 05-25-2008, 04:50 PM   #1
mrpork
SCMC Member
 
Join Date: Apr 2005
Location: rhode island
Posts: 411
Send a message via Yahoo to mrpork
loss of power

a little background. this morning i power washed my motor(going to car show)i made sure no water was down near the plugs. had a little on the last two blew them out. well when i went to put boost to her i was loosing power. i also had a funny noise coming out of the exhaust.what could this be
__________________

ENGINE:2.3whipple 3.25pullie,60lb injectors,spec 3+clutch,fidanza aluminum flywheel,liberty 26 splineinput shaft,fiore firewall adj.clutch quadrant kit,4lb lower, upgraded h/e,upgraded intercooler,k&n cold air kit,hyperflex ploy motor mounts.
FUEL SYSTEM:fore fuel hat,twin gt40 pumps, fore fuel rails,upgraded fpdm(stage2)
INTERIOR:cdc light bar, mgw shifter.
SUSPENSION:h&r race springs,brembo big brake kit up front,poly thru out the irs,billet flow irs brace/irs brackets.
EXTERIOR:fr500 anthracite, kdw'2(275front,295rear)
cobra billet hood vents,black out tail light tint,hid plate light.
AS ALLWAYS MORE MOD'S TO COME
mrpork is offline   Reply With Quote
Old 05-25-2008, 07:08 PM   #2
mrpork
SCMC Member
 
Join Date: Apr 2005
Location: rhode island
Posts: 411
Send a message via Yahoo to mrpork
little update .i took her out after cleaning the mass air meter. she ran great,till she warmed up and then started to miss again .it is making a weird noise out of the exhaust like it is stuttering, a funny popping noise
__________________

ENGINE:2.3whipple 3.25pullie,60lb injectors,spec 3+clutch,fidanza aluminum flywheel,liberty 26 splineinput shaft,fiore firewall adj.clutch quadrant kit,4lb lower, upgraded h/e,upgraded intercooler,k&n cold air kit,hyperflex ploy motor mounts.
FUEL SYSTEM:fore fuel hat,twin gt40 pumps, fore fuel rails,upgraded fpdm(stage2)
INTERIOR:cdc light bar, mgw shifter.
SUSPENSION:h&r race springs,brembo big brake kit up front,poly thru out the irs,billet flow irs brace/irs brackets.
EXTERIOR:fr500 anthracite, kdw'2(275front,295rear)
cobra billet hood vents,black out tail light tint,hid plate light.
AS ALLWAYS MORE MOD'S TO COME
mrpork is offline   Reply With Quote
Old 05-26-2008, 11:40 AM   #3
blk04cobra1
Registered User
 
Join Date: Nov 2004
Location: Charlotte, NC
Posts: 1,374
Does it get in to boost? or does it just stutter once you try to get in to boost? I had a similar issue and it turned out to be a bad IAT sensor (intake sensor).
__________________
2004 Cobra
HP Twin 67's
785rwhp on 9lbs of boost
blk04cobra1 is offline   Reply With Quote
Old 05-26-2008, 12:16 PM   #4
mrpork
SCMC Member
 
Join Date: Apr 2005
Location: rhode island
Posts: 411
Send a message via Yahoo to mrpork
yes it does get into boost ,an as soon as i try to give it full boost it starts to pop out the a$$. but keep in mind when it is a litttle cooler it runs great. it is just when i let it warm up to full engine temp it start this funky sh!t
__________________

ENGINE:2.3whipple 3.25pullie,60lb injectors,spec 3+clutch,fidanza aluminum flywheel,liberty 26 splineinput shaft,fiore firewall adj.clutch quadrant kit,4lb lower, upgraded h/e,upgraded intercooler,k&n cold air kit,hyperflex ploy motor mounts.
FUEL SYSTEM:fore fuel hat,twin gt40 pumps, fore fuel rails,upgraded fpdm(stage2)
INTERIOR:cdc light bar, mgw shifter.
SUSPENSION:h&r race springs,brembo big brake kit up front,poly thru out the irs,billet flow irs brace/irs brackets.
EXTERIOR:fr500 anthracite, kdw'2(275front,295rear)
cobra billet hood vents,black out tail light tint,hid plate light.
AS ALLWAYS MORE MOD'S TO COME
mrpork is offline   Reply With Quote
Old 05-26-2008, 02:30 PM   #5
mrpork
SCMC Member
 
Join Date: Apr 2005
Location: rhode island
Posts: 411
Send a message via Yahoo to mrpork
tttptu
__________________

ENGINE:2.3whipple 3.25pullie,60lb injectors,spec 3+clutch,fidanza aluminum flywheel,liberty 26 splineinput shaft,fiore firewall adj.clutch quadrant kit,4lb lower, upgraded h/e,upgraded intercooler,k&n cold air kit,hyperflex ploy motor mounts.
FUEL SYSTEM:fore fuel hat,twin gt40 pumps, fore fuel rails,upgraded fpdm(stage2)
INTERIOR:cdc light bar, mgw shifter.
SUSPENSION:h&r race springs,brembo big brake kit up front,poly thru out the irs,billet flow irs brace/irs brackets.
EXTERIOR:fr500 anthracite, kdw'2(275front,295rear)
cobra billet hood vents,black out tail light tint,hid plate light.
AS ALLWAYS MORE MOD'S TO COME
mrpork is offline   Reply With Quote
Old 05-26-2008, 05:49 PM   #6
blueblazes
Registered User
 
Join Date: Apr 2006
Location: Hickory, NC
Posts: 277
Send a message via MSN to blueblazes
well when it gets upto operating temp its relying on sensors for information, where as when you first crank the car its running off of what the ecm knows to be good settings. I would scan for codes and see if you got any showing up and go from there. Also make sure you didnt blow any vaccuum lines off anywhere.

Hey torrey shoot me a pm man
__________________
tuned by www.trudynosports.com
transported by www.bigpowercoaches.com
blueblazes is offline   Reply With Quote
Old 05-26-2008, 06:32 PM   #7
mrpork
SCMC Member
 
Join Date: Apr 2005
Location: rhode island
Posts: 411
Send a message via Yahoo to mrpork
Quote:
Originally Posted by blueblazes
well when it gets upto operating temp its relying on sensors for information, where as when you first crank the car its running off of what the ecm knows to be good settings. I would scan for codes and see if you got any showing up and go from there. Also make sure you didnt blow any vaccuum lines off anywhere.

Hey torrey shoot me a pm man
how do i "scan" for codes or is this some thing the dealer has to do
__________________

ENGINE:2.3whipple 3.25pullie,60lb injectors,spec 3+clutch,fidanza aluminum flywheel,liberty 26 splineinput shaft,fiore firewall adj.clutch quadrant kit,4lb lower, upgraded h/e,upgraded intercooler,k&n cold air kit,hyperflex ploy motor mounts.
FUEL SYSTEM:fore fuel hat,twin gt40 pumps, fore fuel rails,upgraded fpdm(stage2)
INTERIOR:cdc light bar, mgw shifter.
SUSPENSION:h&r race springs,brembo big brake kit up front,poly thru out the irs,billet flow irs brace/irs brackets.
EXTERIOR:fr500 anthracite, kdw'2(275front,295rear)
cobra billet hood vents,black out tail light tint,hid plate light.
AS ALLWAYS MORE MOD'S TO COME
mrpork is offline   Reply With Quote
Old 05-26-2008, 07:10 PM   #8
RF Cobra
Registered User
 
RF Cobra's Avatar
 
Join Date: Jun 2004
Location: Clemmons, NC
Posts: 1,567
Most chain auto parts stores like Advance Auto will scan for codes for you for free and give you a printout of what they find.


Quote:
Originally Posted by mrpork
how do i "scan" for codes or is this some thing the dealer has to do
RF Cobra is offline   Reply With Quote
Old 05-26-2008, 08:14 PM   #9
mrpork
SCMC Member
 
Join Date: Apr 2005
Location: rhode island
Posts: 411
Send a message via Yahoo to mrpork
Quote:
Originally Posted by RF Cobra
Most chain auto parts stores like Advance Auto will scan for
codes for you for free and give you a printout of what they find.
thank you very much
__________________

ENGINE:2.3whipple 3.25pullie,60lb injectors,spec 3+clutch,fidanza aluminum flywheel,liberty 26 splineinput shaft,fiore firewall adj.clutch quadrant kit,4lb lower, upgraded h/e,upgraded intercooler,k&n cold air kit,hyperflex ploy motor mounts.
FUEL SYSTEM:fore fuel hat,twin gt40 pumps, fore fuel rails,upgraded fpdm(stage2)
INTERIOR:cdc light bar, mgw shifter.
SUSPENSION:h&r race springs,brembo big brake kit up front,poly thru out the irs,billet flow irs brace/irs brackets.
EXTERIOR:fr500 anthracite, kdw'2(275front,295rear)
cobra billet hood vents,black out tail light tint,hid plate light.
AS ALLWAYS MORE MOD'S TO COME
mrpork is offline   Reply With Quote
Old 05-26-2008, 11:15 PM   #10
Big T
Registered User
 
Join Date: Feb 2004
Location: Madisonville, Louisiana
Posts: 249
Quote:
Originally Posted by mrpork
thank you very much
You can scan for codes with a handheld tuner (predator/ Superchips) if you are using one to hold your tunes. If you are modding your car, It is very handy to have the ability to scan for error codes.
__________________
2003 black anniversary edition cobra

Current Mods:

Polished 2.3L whipple
Kenne Bell BAP
60# injectors
SCT BA 2600
3.5 whipple pulley with aux idler kit
2# LFP lower pulley
dyno tune by L&L Automotive
flowmaster american thunder catback
bbk x-pipe with high flow cats
bbk cai
Accufab polished TB
polished canton coolant reservoir tank
LFP dual pass heat exchanger
Polished intercooler reservoir tank
upr polished underhood kit with hood prop
Autolite racing spark plugs .032 gap
hilton boost overlay
Mickey Thompson ET Streets 275/40/17
566rwhp 536rwtq on mustang dyno

Mods to come soon in order:
suspension upgrade
2.75 upper pulley waiting for install
Big T is offline   Reply With Quote
Old 05-26-2008, 11:21 PM   #11
mrpork
SCMC Member
 
Join Date: Apr 2005
Location: rhode island
Posts: 411
Send a message via Yahoo to mrpork
Quote:
Originally Posted by Big T
You can scan for codes with a handheld tuner (predator/ Superchips) if you are using one to hold your tunes. If you are modding your car, It is very handy to have the ability to scan for error codes.
i have a sct tuner
__________________

ENGINE:2.3whipple 3.25pullie,60lb injectors,spec 3+clutch,fidanza aluminum flywheel,liberty 26 splineinput shaft,fiore firewall adj.clutch quadrant kit,4lb lower, upgraded h/e,upgraded intercooler,k&n cold air kit,hyperflex ploy motor mounts.
FUEL SYSTEM:fore fuel hat,twin gt40 pumps, fore fuel rails,upgraded fpdm(stage2)
INTERIOR:cdc light bar, mgw shifter.
SUSPENSION:h&r race springs,brembo big brake kit up front,poly thru out the irs,billet flow irs brace/irs brackets.
EXTERIOR:fr500 anthracite, kdw'2(275front,295rear)
cobra billet hood vents,black out tail light tint,hid plate light.
AS ALLWAYS MORE MOD'S TO COME
mrpork is offline   Reply With Quote
Old 06-02-2008, 11:04 PM   #12
Big T
Registered User
 
Join Date: Feb 2004
Location: Madisonville, Louisiana
Posts: 249
Did you find any codes? What's your progress?
__________________
2003 black anniversary edition cobra

Current Mods:

Polished 2.3L whipple
Kenne Bell BAP
60# injectors
SCT BA 2600
3.5 whipple pulley with aux idler kit
2# LFP lower pulley
dyno tune by L&L Automotive
flowmaster american thunder catback
bbk x-pipe with high flow cats
bbk cai
Accufab polished TB
polished canton coolant reservoir tank
LFP dual pass heat exchanger
Polished intercooler reservoir tank
upr polished underhood kit with hood prop
Autolite racing spark plugs .032 gap
hilton boost overlay
Mickey Thompson ET Streets 275/40/17
566rwhp 536rwtq on mustang dyno

Mods to come soon in order:
suspension upgrade
2.75 upper pulley waiting for install
Big T is offline   Reply With Quote
Old 06-04-2008, 02:27 PM   #13
mrpork
SCMC Member
 
Join Date: Apr 2005
Location: rhode island
Posts: 411
Send a message via Yahoo to mrpork
Quote:
Originally Posted by Big T
Did you find any codes? What's your progress?
nope no codes at all. car is just sitting hoping all i did was get a little water where it should not be. maybe it will dry out .
__________________

ENGINE:2.3whipple 3.25pullie,60lb injectors,spec 3+clutch,fidanza aluminum flywheel,liberty 26 splineinput shaft,fiore firewall adj.clutch quadrant kit,4lb lower, upgraded h/e,upgraded intercooler,k&n cold air kit,hyperflex ploy motor mounts.
FUEL SYSTEM:fore fuel hat,twin gt40 pumps, fore fuel rails,upgraded fpdm(stage2)
INTERIOR:cdc light bar, mgw shifter.
SUSPENSION:h&r race springs,brembo big brake kit up front,poly thru out the irs,billet flow irs brace/irs brackets.
EXTERIOR:fr500 anthracite, kdw'2(275front,295rear)
cobra billet hood vents,black out tail light tint,hid plate light.
AS ALLWAYS MORE MOD'S TO COME
mrpork is offline   Reply With Quote
Old 05-22-2009, 08:11 AM   #14
ausie
Don't let the dog drive
 
ausie's Avatar
 
Join Date: Apr 2004
Location: Kinston, NC
Posts: 1,883
Send a message via MSN to ausie
Just recently experienced the same problem

Three days ago had the same problem. Happened with engine cold and hot. Engine ran strong up to 4500 RPM at moderate boost but when boost reached maximum level the engine failed to produce power. Exaust sounded like a machine gun (noise may be different depending on catback exhaust). Only mods on my car that would influence power is the catback (everything else is essentially stock including the tune).

Suspect timming issue. The 03/04 stock tune has a timing change that occurs at around 5000RPM which is an advance in timming. However, when the issue occured, it acted like a retard when the RPM reached the turnover point under boost. I susptected the spark plugs may be at fault. No error codes pending or "check engine" light. No miss-fire detected.

History of vehicle: This past winter, my car remained inactive. Engine ran perfectly early this spring with the old gas in the tank. Went through three tanks of fuel so old gas was not an issue. The only thing that changed from my usual regime was when I changed the oil. I did not use Royal Purple or AMSOIL due to high cost. This time I used Mobil 1 (something I had avoided for a long time, I had my reasons but this is not to debate oil brands). Note: during the winter months, the battery lost charge and the indicator bar on the battery changed color to red. It took a few days of driving to regain the charge on the battery. A few times all of the guages would reset indicating that the operating parameters that are accumulated to regulate A/F have been lost. Original spark plugs are still in the car but they do not have the full milage since I ran Desno's for a few years until one failed.

When the issue occured on my way to work, I got off the throttle to keep out of boost. I suspected there may be a poor flow of fuel through the injectors. ( One may suspect fuel filter, but it was changed last summer.) It is possible that there may be some debris in the filter or in the injectors due to the car sitting for a long time without use. That same moring, I got some Lucas oil "tune-up in a bottle" and added it to a near empty tank then filled up with new gas. It took a day of driving the car to clear the problem. The next day, engine ran great at WOT and full boost.

I will still change the plugs, but not sure what the issue is or was. It may have been fuel related, or carbon on the plugs (I will find out more when I replace the plugs this weekend).
__________________
2004 SVT Cobra, Silver, February 2004
SVT Build # 2485 out of 3768
SLP Loudmouth Cat-back
UPR double lock firewall adjuster
UPR GMS extreme double hook quadrant
Wheels: Ford SVT 10th anniv. wheels (track duty)
SVE 10th anniv. style 17x9F, 10x10.5R
BBS RK Plasma 18x8.5F, 18x10R (retired)


(retired) 2001 black SVT Cobra, October 2001
missed but not forgotten
ausie is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 01:37 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 1999-2017 SCMC, Inc