SCMC Message Forum  
Go Back   SCMC Message Forum > SVT Platforms > 96 - 01 SVT Cobra Forum
User Name
Password

Register FAQ Members List SCMC Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread
Old 08-04-2008, 10:25 AM   #1
decco
Registered User
 
Join Date: Jul 2008
Location: Vail, AZ
Posts: 10
rattle in the front end

I've got a rattle in the front brakes somewhere. It sounds like the brake pads are rattling, and when I put light pressure on the brake pedal, the noise goes away. I pulled the calipers, and was going to put disc brake quiet on the pads, but they were firmly attached to the caliper, as they should be. The caliper seems to be mounted in rubber mounts where it attaches to the caliper bracket, and that seemed a little loose, but not horribly so. The rattle only occurs on those sharp little bumps like cracks in the pavement. Any one else have this problem, and if you cured it, how did you do it? Was it just a matter of replacing those rubber caliper mounts, if they're available? Thanks.
decco is offline   Reply With Quote
Old 08-06-2008, 10:07 AM   #2
brkntrxn
Registered User
 
Join Date: Mar 2007
Location: NC
Posts: 99
Do your brake pads still have the anti-rattle clips on each end?
__________________
2003 Corvette Z06
2001 triple black Cobra vert
brkntrxn is offline   Reply With Quote
Old 08-06-2008, 12:33 PM   #3
decco
Registered User
 
Join Date: Jul 2008
Location: Vail, AZ
Posts: 10
Yes they do, and they're secure to the caliper. I've had it up on the lift, checked, wiggled, and pushed on everything, and can't find the source of the rattle.
decco is offline   Reply With Quote
Old 08-08-2008, 05:34 PM   #4
pacificgreensvt
Registered User
 
Join Date: Oct 2006
Location: ROYALOAK MI
Posts: 18
Its the the anti-rattle clips try bending them out a little, or get new ones.
__________________
v1 s/trim, GT/impeller,longtubes,4:30's.424hp/412tq,race fuel & street tune by Alternative.
pacificgreensvt is offline   Reply With Quote
Old 08-11-2008, 03:33 PM   #5
decco
Registered User
 
Join Date: Jul 2008
Location: Vail, AZ
Posts: 10
Guess I'll have to pull 'em out and try bending them. Hope that will stop it. Thanks.
decco is offline   Reply With Quote
Old 08-13-2008, 03:19 PM   #6
2092CobraMadeIn98
SCMC Member
 
Join Date: Jan 2008
Location: Plymouth Michigan
Posts: 51
Send a message via AIM to 2092CobraMadeIn98
I have the same issue on my car. One of my friends Steve works at Ford on Team Mustang and said he will ask some of his co workers. He said he's not to sure what it would be. But I do have the same issue and it is embarrasing and annoying!
__________________
Flirtin' with Disaster.


love ya mom, stay strong!
2092CobraMadeIn98 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 01:52 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 1999-2017 SCMC, Inc