SCMC Message Forum  
Go Back   SCMC Message Forum > SVT Platforms > 96 - 01 SVT Cobra Forum
User Name
Password

Register FAQ Members List SCMC Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread
Old 01-22-2009, 12:48 AM   #1
Z_Drifter_87
Registered User
 
Join Date: Jan 2009
Location: Harlingen, TX
Posts: 28
Gauge question...

Well i'm not sure if its a connection or fuse or even something i can fix. My odometer just stopped marking the mileage. everything else works, just no trip or odometer. is there a quik fix for this? thanks
Z_Drifter_87 is offline   Reply With Quote
Old 01-22-2009, 06:58 AM   #2
Larry95
SCMC Member
 
Join Date: May 2006
Location: Richmond, TX
Posts: 469
More than likely the plastic gear has broke.

http://www.odometergears.com/ford.html
__________________
Larry & Eloisa Ewers

'95 Red Coupe #684/4005 (going back to stock)
'95 White Coupe (track car)(378 rwhp, 394 rwtq)
'03 Red Annv Convt #711/2003 (SOLD)
'12 Boss 302 LS
'13 King Ranch EcoBoost F-150 (Eloisa's ride)
'13 King Ranch 6.7L F-250 (daily driver & tow vehicle)
Larry95 is offline   Reply With Quote
Old 01-24-2009, 09:21 AM   #3
flynfink
Registered User
 
Join Date: Jun 2001
Location: Concord, NC
Posts: 1,014
Send a message via AIM to flynfink
Larry95 - tnx for the link, our 94's odo quit years ago. thought only fix was replace dash.
__________________
Jeff F.
AKA FlynFink
07' Porscha Cayman S
99' Rio Red Cobra Vert. #203 of 4055
94' Black Cobra Coupe #4971 of 5009

"Drive it like ya stole it"
flynfink is offline   Reply With Quote
Old 01-26-2009, 04:52 PM   #4
Z_Drifter_87
Registered User
 
Join Date: Jan 2009
Location: Harlingen, TX
Posts: 28
Thanks Larry 95

Appreciate the info. Will try and will reply with results.
Z_Drifter_87 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 03:13 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 1999-2017 SCMC, Inc