SCMC Message Forum  
Go Back   SCMC Message Forum > Pick your poison > Suspension Tech
User Name
Password

Register FAQ Members List SCMC Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread
Old 05-21-2009, 12:10 AM   #1
Lumpydogs
Registered User
 
Lumpydogs's Avatar
 
Join Date: Sep 2003
Location: Southeast Michigan
Posts: 517
Steering is all screwed up...

Gonna try flushing the power steering fluid. Can't find anything else wrong.
__________________
Lumpydog
2001 Cobra Coupe
NA Mod Motor 329 rwhp 344 rwtq

www.lumpydogmotorsports.com
Lumpydogs is offline   Reply With Quote
Old 05-21-2009, 12:16 AM   #2
cfradam
Registered User
 
cfradam's Avatar
 
Join Date: Feb 2008
Location: orlando
Posts: 121
whats it doing?
cfradam is offline   Reply With Quote
Old 05-21-2009, 08:11 PM   #3
Lumpydogs
Registered User
 
Lumpydogs's Avatar
 
Join Date: Sep 2003
Location: Southeast Michigan
Posts: 517
Hard to explain. How about this.

Car tracks straight with the steering wheel straight.
Make a hard right turn and then the steering wheel needs to be slightly turned to the right to track the car straight. Hard turn left and the steering wheel goes back to straight. Another hard turn left and the steering wheel needs to be turned slightly to the left to track the car straight.

It's like the relationship between the steering wheel and the steering rack is not staying the same.

The steering is smooth and easy. No fluid leaks and fluid level is good. No power steering pump squeaks. No noticeable steering wheel slop.

Could the pinion be jumping a tooth on the rack?
__________________
Lumpydog
2001 Cobra Coupe
NA Mod Motor 329 rwhp 344 rwtq

www.lumpydogmotorsports.com
Lumpydogs is offline   Reply With Quote
Old 05-22-2009, 02:36 PM   #4
cfradam
Registered User
 
cfradam's Avatar
 
Join Date: Feb 2008
Location: orlando
Posts: 121
It does sound like there is something wrong with the rack or the rack bushings
cfradam is offline   Reply With Quote
Old 05-22-2009, 05:21 PM   #5
Lumpydogs
Registered User
 
Lumpydogs's Avatar
 
Join Date: Sep 2003
Location: Southeast Michigan
Posts: 517
Rack bushings are aluminum. Had the car on jack stands. No slop between wheels, no loose steering rack and rod ends are good. The fluid flush didn't help. The flushed fluid looked like new.

Looks like it's feeding for the the bottomless money pit again. What are new racks, about $1000
__________________
Lumpydog
2001 Cobra Coupe
NA Mod Motor 329 rwhp 344 rwtq

www.lumpydogmotorsports.com
Lumpydogs is offline   Reply With Quote
Old 06-10-2009, 08:41 PM   #6
Philcsag1
SCMC Member
 
Join Date: Mar 2005
Location: New York City
Posts: 115
check the rag joint on the steering shaft

also did you bleed the system with the PS flid bleeder on the Hydro boost?
__________________
1993 Cobra # 329, Cover Car Fox Body Recognition Guide
1994 Cobra Convertible # 73 sold 11-11-2011
1995 Cobra R #45
2012 Boss 302 LS #699
Philcsag1 is offline   Reply With Quote
Old 06-11-2009, 06:45 PM   #7
Lumpydogs
Registered User
 
Lumpydogs's Avatar
 
Join Date: Sep 2003
Location: Southeast Michigan
Posts: 517
Good idea. I pull out the steering shaft and take a closer look at the rag joint.
__________________
Lumpydog
2001 Cobra Coupe
NA Mod Motor 329 rwhp 344 rwtq

www.lumpydogmotorsports.com
Lumpydogs is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 11:13 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 1999-2017 SCMC, Inc