SCMC Message Forum  
Go Back   SCMC Message Forum > SVT Platforms > 96 - 01 SVT Cobra Forum
User Name
Password

Register FAQ Members List SCMC Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread
Old 06-04-2010, 11:42 PM   #1
CobraBro
Registered User
 
Join Date: May 2010
Location: Atl, GA
Posts: 4
Newbie with a couple of ?'s

Howdy fellow Cobra owners,
I am now the proud owner of a 98 Cobra with low miles (56k) that seems to be in really good shape and I am happy to be back in a stang after piloting a few sporty sedans for the past few years.

One question I have is regarding how smooth the idle should be?
The cars runs just fine but at idle sometimes, it feels a little lumpy.

Is this normal or something I should look into? I know the motor shouldn't need new plugs at 56k but then again they are 12 years old also.

Any Thoughts?
CobraBro is offline   Reply With Quote
Old 06-05-2010, 03:12 PM   #2
nckissfan
Everyone hates a winner!
 
nckissfan's Avatar
 
Join Date: Jan 2004
Location: Browns Summit, NC
Posts: 2,849
Send a message via Yahoo to nckissfan
welcome. It probably wouldn't hurt to change plugs. Where is the idle at, rpm wise?
__________________
nckissfan is offline   Reply With Quote
Old 06-05-2010, 09:11 PM   #3
CobraBro
Registered User
 
Join Date: May 2010
Location: Atl, GA
Posts: 4
Looks like it is consistantly idleing @ 850 rpm. Does that sound about right?
CobraBro is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 02:40 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 1999-2017 SCMC, Inc