SCMC Message Forum  
Go Back   SCMC Message Forum > SVT Platforms > 96 - 01 SVT Cobra Forum
User Name
Password

Register FAQ Members List SCMC Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread
Old 07-05-2010, 11:30 PM   #1
66gtstang
Registered User
 
Join Date: Nov 2009
Posts: 3
Clutch Woes

It's been a lonnnng time since I've had a stick car and today I was driving my 96 Cobra when I heard a noise from underneath and my clutch went out on me. the pedal all of a sudden whent hard as a block of concrete (It would go down, but with a lot of pressure) and the clutch would not fully engage at the top of travel. I could nurse it back to my house, but there is something seriously wrong with the clutch. I disconnected the cable, at the fork, and the pedal had no resistance, but it took a lot of pressure, with a big pry bar, to engage the clutch at the fork. So I guess this means it time to replace the clutch, PP & TO Bearing. Any other thoughts on what went wrong? It was all of a sudden - worked 1 second, heard the noise ( Oh yeah the dirt shield had come loose and was wedged between the fork & Cat Converter maybe this caused a problem?) and then it didn't work. If it is a new clutch any tips on a good unit to buy? I want the most bang for the buck and don't want to spend a lot unless I have to. It's a daily driver and eventually I will do some mild drag and autocross racing with it. As far as I know it's pretty much a stock Cobra.
66gtstang is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 05:51 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 1999-2017 SCMC, Inc