SCMC Message Forum  
Go Back   SCMC Message Forum > SVT Platforms > 93 - 95 SVT Cobra Forum
User Name
Password

Register FAQ Members List SCMC Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread
Old 04-13-2005, 01:40 AM   #1
1Low94Cobra
Registered User
 
Join Date: Apr 2005
Location: Connecticut
Posts: 2
Send a message via AIM to 1Low94Cobra
A few tech questions for the newb...

Hey, im a little new here so give me a break. I usally talk on Probetalk.com .. anyways, i have a 94 Cobra.Now , somewhere there is an exhaust leak ... Its a rubber pipeing (high temp hose) i think is crack NOT sure... Its like, when i accelorate it makes a Tick tick tick... not a valve tick though...
Problem 2!
- i cant seem to get my timeing right... my car feel really loady an spudders a little since i tried adjusting my timeing ( dont try to fix stuff thats not broken)... So now its acting funny... is there any little Mustang Pointers SOMEONE could help me out with!! Please!! i have every bolt on mod there is, an gears ect ect... Would it be my chip ?

Thanks For Some feed back fellas ! Thank you Kindly !
1Low94Cobra is offline   Reply With Quote
Old 04-13-2005, 08:37 AM   #2
venomous
Polk County Redneck
 
venomous's Avatar
 
Join Date: Feb 2003
Location: Polk County, NC
Posts: 557
Send a message via AIM to venomous Send a message via Yahoo to venomous
MAF maybe?
__________________
~1995 "Rio Red" Cobra #3379 of 4005
2.2 Kenne Bell Blowzilla/ Flowzilla Supercharger (12# Boost), AFR 165 Aluminum Heads 61cc, TMoss Port Matched Cobra Lower, Trickflow 1.7 Roller Rockers, Crane 2031 Camshaft, 3/8" Intake Spacer, 60# Injectors, Accufab 75mm Throttle Body w/ Blank Spacer, DynoJet Wideband Commander, MSD Pro Billet Distributor, MSD Blaster Coil, SCT Big Mouth Meter BAF 2400, JLT Custom Cold Air intake, Deleted EGR/ Smog, Mac Chrome Radiator Pipes, Mac Ceramic Coated Shorty Headers, Mac O/R H-Pipe, Flowmaster Cat-Back, Pro 5.0 Shifter, Ford Racing 3:73 Gears, H&R Sport Springs, Chrome Cobra R Wheels
Pro Dyno Tuned to 498 RWHP 497 RWTQ
venomous is offline   Reply With Quote
Old 04-13-2005, 10:58 PM   #3
fivelinkcobra
Registered User
 
Join Date: Mar 2005
Location: Lansing MI
Posts: 6
When seting the timming you have to pull he spout connecter,I think it is by the air box. Pull spout connecter, start car, set timming tunr car off and replace connecter.
fivelinkcobra is offline   Reply With Quote
Old 04-14-2005, 12:06 AM   #4
cobrapace94
Registered User
 
cobrapace94's Avatar
 
Join Date: Nov 2001
Location: Houston (Humble), Tx.
Posts: 1,119
Send a message via AIM to cobrapace94
If it is the rubber tubing, you probly have a aftermarket mid pipe & the tube goes from the air pump to the mid pipe by the cats. It's just a high temp hose that can be replaced.
As stated, you need to remove the spout, passenger side engine compartment, to set the timing. Check the balancer to make sure it is not wobbling or the rubber is not sticking out on it. 94\95 balancers are known for going bad.
__________________



1994 Cobra Indy Pace Car Convertible # 591 of 1000
2001 Cobra, #2001 of 3384 verts, Black on White, Born on 6/01/01
cobrapace94 is offline   Reply With Quote
Old 04-14-2005, 01:01 AM   #5
1Low94Cobra
Registered User
 
Join Date: Apr 2005
Location: Connecticut
Posts: 2
Send a message via AIM to 1Low94Cobra
yeah, im going to jack it up in the morning. i have a Probe with nitrous on it, its my daily drive fun little rocket. i did a top end flush (pcv valve flush). Wow what a difference. Would it work the same on the Cobra ?
1Low94Cobra is offline   Reply With Quote
Old 04-21-2005, 05:23 PM   #6
Aaron94
Registered User
 
Aaron94's Avatar
 
Join Date: Feb 2003
Location: Riverside, CA
Posts: 309
Send a message via AIM to Aaron94 Send a message via Yahoo to Aaron94
Check all of the hoses going in and out of the smog pump. I had a couple of these crack open on me, and i had a really annoying exhaust leak type sound. Long story short i ripped out the smog pump and all of its hoses, and run a short belt now...
__________________


1994 Rio Red Coupe #3564

304 ci, GT40X Aluminum Heads, Extrude Honed and Polished intake, Motorsport F303 cam, vortech fuel rails, 77 mm Pro-M mass air, 70mm BBK T-Body, Smog pump deletion, MSD and Perfomance distributors ignition components, Tremec 3550, Steeda Tri-axe, King Cobra/Centerforce clutch, Custom 3" Alum Driveshaft, 3.55 Gears, Griggs rear suspension w/torque arm & pan hard bar, Koni Red Shocks/Struts
Aaron94 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 06:34 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 1999-2017 SCMC, Inc